The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums Other Very confusing URL problem

  • This topic is empty.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #31089

    Could someone help me with a problem I’ve recently had, basically I had to change the IP of the domain name, because of a server change, I did this, and it worked fine, I went to and it was up, great, so I left it, a few days later, the owner called me up and told me the site still wasn’t up, I told him it was and while on the phone I went to the site, it was still up, he insisted it wasn’t and said it came up with an IIS7 page, he then got round to telling me he was visiting which weirdly does come up with the IIS7 page, but take the www. out the actual site comes up. Why is this? the domain IP is changed and I’m pretty sure it is correct.



    Im definately not a server guru, but did you check the .htaccess file? I don’t know if it has anything to do with it but it’s always worth the shot.

    If that doesn’t help you just email the hoster, i’m sure they will be able to fix it.


    After doing some investigating it seems like is pointing to a different location on the server than I am guessing the www is looking at the default website folder for IIS7 and no www is looking is a custom folder you setup to host the website. So basically there is a setting screwed up somewhere in your configuration.

    One other thing I noticed is when you enter the IP of your server manually the IIS7 page comes up. (

    Not sure if this is any help but the above is what I think the problem is, not sure how to exactly fix this. I am not very familiar with IIS.


    a ping to the 2 separate addresses shows them go to the same address ( so the DNS’s are pointing the right way. It is likely a server config issue. One that you may or may not be able to fix yourself. Submit a ticket to your hosting company.

    You can also try this to mask the problem. Place this in your .htaccess in the web root:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^$ [NC]
    RewriteRule ^(.*)$$1 [R=301,L]

    It might not work if the server is hosting information from a completely different (internal) location, if that is the case then you need to wait on your hosting company.

    ***EDIT*** the .htaccess won’t work… it’s an Apache server ‘thing’. If your host is actually using IIS7 then it will ignore it. Sorry – My post itself has been unedited so you can see I meant well :-)

    Merry Christmas


    You’ll need to check the Bindings for the site in IIS. I’m guessing something in there isn’t pointing to the right place.

    Off the top of my head (Office is closed and I have a Mac without any of this installed) I think you need to open IIS, go to the site and then in the right hand column there should be something that says ‘Edit Bindings’


    Thank you so much for all the help, I’d checked at least 20 times over the last few days, and I’ve definitely put the right IP in, and I did try going straight to and the IIS7 page came up, that’s the new IP. I’ve emailed someone from the hosting company, hopefully he can fix this on his side.

    With regards to the .htaccess, I hadn’t touched that at all, it worked before the server changed, and in the DNS settings I changed the IP in 2 places, one was www. and I think the other was just * so I thought I’d be done.

    As I said, I’ll see if my hosting company can tell me if its an issue on their side, it’s complicated but I don’t have control of the hosting, only the domain name.

    Thanks again for all the help, You all knew more than me.


    Ah, you won’t be able to do much without access to the hosting controls.

    In any case, you’re hosting on a Windows server and so do not have an .htaccess file


    I know, they are pretty helpful, and I’m confident they’ll fix it for me.


    Both domains are indeed resolving to the same IP address: My bet is that either the headers for the www address are not setup to resolve to the correct website in IIS.

    As TT_Mark mentioned, his is very easily corrected with access to the IIS server. I would add however that the correct procedure would be to perform a 301 redirect on one of those domains (pointing it to the other). So resolved to or visa versa. This will prevent issues with users, logins, cookies bookmarks, etc and also theoretically help your SEO as Google can see duplicate content on two domains. It’s also good practice to 301 all domains to a “primary” domain for these reasons.

    Here is a god article on the process:


    Thanks, I emailed them, and it’s all fixed now, www. directs to the correct site. since it was a new server, something wasn’t setup correctly, it’s since been fixed. But I will definately look into what everyone has told me.

    Thanks again.

Viewing 10 posts - 1 through 10 (of 10 total)
  • The forum ‘Other’ is closed to new topics and replies.