The Lodge is members-only design/dev videos and Office Hours.

Next Office Hours Session: "Implementing an SVG Icon System" Nov 30 - 6:00 PM Eastern

Twitter Bootstrap for WordPress (bootstrap.js not working)

  • # October 6, 2012 at 9:24 am


    i am creating a template for wordpress using twitter bootstrap, but it looks wordpress does not like it.

    i cannot access any functions from the bootstrap.js

    does anyone know, how to fix this ?

    thanks for any help.

    # October 13, 2012 at 12:25 pm

    I need more info to troubleshoot this, but I am going to start you out with:

    Wordpress is set up so that jQuery has to use the word “jQuery” instead of the dollar sign. So instead of


    it is


    This is a WordPress thing, not a bootstrap thing. Give this a try and post back here if you want more help.

    # October 15, 2012 at 7:08 pm

    This reply has been reported for inappropriate content.


    well, i tried doing jQuery(“#myModal”).modal(),

    but it ends up saying .modal() is not a function, i thought this might be an error , i tried replacing all $ with jQuery, but did not work.

    currently i get an error log in console .

    TypeError: $ is not a function
    [Break On This Error]

    $(function () {

    Line 23 – bootstrap.js

    i tried replacing all $ on bootstrap but no success. i will still have a look and post here, if i need more help, thanks anyways.

    # October 15, 2012 at 7:12 pm

    This reply has been reported for inappropriate content.

    ( “Experiment”)

    This is what i’ve been working lately and if you click on personalise icon at bottom, a modal window appears, now this modal uses styles from bootstrap but not the modal() – function.

    so, i want to use modal function instead.

    This is an experiment to create windows 8 interface and is still being built. hopefully should be a success.

    Thanks again.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

There's a whole bunch of content on CSS-Tricks.

Search for Stuff   •   Browse the Archives

Get the Newsletter ... or get the RSS feed