The Lodge is members-only design/dev videos and Office Hours.

Next Office Hours Session: "Implementing an SVG Icon System" Nov 30 - 6:00 PM Eastern

SVG not showing?

  • # March 14, 2013 at 9:14 pm

    Hello, for some reason I cannot get an svg image to show using

    and so on…

    Any suggestions?

    # March 14, 2013 at 9:21 pm

    Why would you write a function that accepts and returns a string that would just otherwise work without the PHP function? I don’t get it.

    Why not just write ``

    Am I missing something?

    # March 14, 2013 at 9:25 pm

    I’m trying everything here… tried what you have. Still nothing.

    # March 14, 2013 at 9:29 pm

    Where is the image located, in your directory structure, relative to the page you are trying to render it?

    # March 14, 2013 at 9:34 pm

    out two folders and in the assets/images

    # March 14, 2013 at 9:38 pm

    Well first of all, you have bunch of HTML syntax errors. This could be source of your problem.

    Here’s possible HTML structure for your page (CSS is incomplete, but you get the idea how to continue coding)

    # March 14, 2013 at 11:23 pm

    Thank you

    # March 15, 2013 at 6:53 am

    It’s solved? I’m seeing the svg image, at least in Chrome.

    # March 15, 2013 at 7:29 am

    Chrome & FF & Safari & IE9/10 (standards)

    IE8 standards (via F12 in IE10) borks.

    # March 15, 2013 at 11:40 am

    To avoid confusion possible double post:

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

There's a whole bunch of content on CSS-Tricks.

Search for Stuff   •   Browse the Archives

Get the Newsletter ... or get the RSS feed