The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums Other Remove :8888 from MAMP URL

  • This topic is empty.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #45805

    Using MAMP Pro, by default websites are: localhost/whateveritis:8888

    Is there a way to remove the ‘:8888’ and just put in localhost/whateveritis?

    Watching Chris’ screencasts there is a way to do this, I just don’t know how.


    It should be `localhost:8888/folder`

    I’ve never used MAMP so not really sure, but look into Virtual Host settings. What MAMP is doing is just routing to the 8888 port so there’s no conflicts with other services you are running.


    In MAMP preferences, go to ports and hit “Reset Ports”. Then Command+Q to quit MAMP. In Terminal type `sudo apachectl stop`. Restart MAMP, go to ports and click “Set to Default”. Then in terminal again type `sudo apachectl restart` and you should be good to go


    If you use the default ports rather than the mamp ports it removes the 8888. This used to annoy me as you want / to take you to the root.

    If you haven’t already I’d get the pro version it just makes setting up domains really easy and quick.


    [Attachment]( “Image”)

    Set MAMP ports to APACHE=80 SSL=443 MYSQL=3306

    Those are the default ports… not the MAMP ports. MAMP comes defaulted to its own ports.


    Or just leave it as is. Why fix something that is not broken. Why don’t you focus on, you know, developing, instead of fiddling with settings, that make no difference.


    There is always 97 ways to do any 1 thing. And knowing is half the battle.

    [GI Joe]( “GIJoe”)


    Knowing is good, but doing is better.


    AlenAbdula, you’re a burden to the world.
    SilverSerpent thanks that worked just fine.


    In the past, I’ve spent countless hours reworking my dev environment instead of focusing on doing the actual work. At the end of the day, it’s the work, things we make, that matter. Once the website goes live :8888 is irrelevant.

    My local paths look like this `http://localhost/wordpress/project_folder`. For me I want to focus on doing what I enjoy doing, and not fiddling with Apache settings.

    I don’t think am a burden. I’m just trying to help.

    Go SOX! :) You watching the game? I’m at my desk listening to WEEI feed.



    Not everyone works the way you do. One of the benefits of changing things is to be consistent – especially if working on a team or in multiple environments, local, dev, prod, stage etc.

    If you are in localhost:8888, and someone else is in dev.local or something else things get weird.

Viewing 11 posts - 1 through 11 (of 11 total)
  • The forum ‘Other’ is closed to new topics and replies.