The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums Back End Having major issues with Permalinks – Getting 404 Error

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #145867

    I hope I posted in the correct category fellas . . .

    I’m a newbie to CSS Forums. Hoping to get some answers now and again and maybe help out as well.
    My question is, I have (2) blog posts, and for some reason the latest one gives me a 404 Error message when I try to view it. See for your self :

    I contacted the theme developer and all he did was select the “default” setting for the permalinks. I don’t want the post ID, I want the /%postname%/
    I hear it could be an .htacces issue, so I contacted my host, but they basically said it wasn’t their problem. Good ol’ Bluehost.
    Any ideas guys?

    Thank you


    I don’t know for sure what is happening to your site, since I don’t usually work with a CMS, but I think you could just check in your database (often the hoster even has a UI for it, so you don’t need to know much) the field of the ID of the link. But it seems very strange that the short description can be loaded with the link to the full version, since I think this would just be solved with one request to your database.

    My guess would be, that either somehow no text was saved and just the description, id and image field in the database are filled or that as you said it could be an .htacess issue. Maybe your software tries to load the text but since there is no text it displays a 404 page. But this is just me guessing, since we don’t know anything about your database structure or your htacess file.


    Hello Malte,

    Thanks for the response. This IS an odd one. I think it’s the .htaccess file—although Bluehost would not even consider looking into it. I do have text on the main post. That’s a good thought though. Not sure about the ID and the image field situation as you mentioned. A little over my head. :-)

    I’ve posted this issue in a couple different forums and you’re the only one that has contributed so far. ;-(

    It’s bad because this is the only thing holding up the launch. As #ChrisLema says: ever problem has a resolution. I’ll find it at some point.

    Thanks buddy.



    Ok, I feel silly. After stumbling upon Digging Into WP’s blog I was able to fix it by changing the permalinks to /%year%/%postname%/

    I guess I was overlooking the most simple options.

    Thanks again Malte for contributing.

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Back End’ is closed to new topics and replies.