I have to make it dynamic because I’m calling it from a click and checking some things before deciding which function to call. For example I’m checking screen size and then calling functions based on that as well as another value. The two put together make up the existing function name.
I was thinking of using a switch statement but that would bloat the code and I was really hoping for less code to manage and hopefully a smaller file size. Looks like the method @traq suggested seems to be the better option.