Grow your CSS skills. Land your dream job.

Background images don’t load in IE7

  • # March 14, 2009 at 6:02 pm

    Hi,

    My background images are not loading in IE7, although they do fine in FF and Safari.

    Would someone mind taking a look at [url]http:dev.craigcurry.com[/url] and pointing me in the right direction? I’m guessing it’s some kind of float issue? Or is it related to the Google map code?

    Thanks.

    Craig

    # March 14, 2009 at 6:54 pm

    Don’t have access to IE right now but I’ve just chcked the page out with firebug on the mac and with your existing path to your images directory

    Code:
    background:#730707 url(../images/interface/body_bg_03.jpg) repeat-x scroll 0 0;

    firebug can’t find the images. But if I delete the two periods

    Code:
    background:#730707 url(/images/interface/body_bg_03.jpg) repeat-x scroll 0 0;

    then firebug finds them.
    Does that help?

    # March 14, 2009 at 11:24 pm

    That does help, thanks. I think I’ve got it fixed now. What is odd is that I’m on Mac also, and it was loading just fine for me. I had the page up on Safari on a friend’s Mac also with the images loading.

    I’ve been working on learning Expression Engine and had the css file stored in there. But after your post I noticed when I used firebug that the css file had a really long title formed by php. I moved it to a static URL and that seemed to do the trick.

    Thank you!!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".