Grow your CSS skills. Land your dream job.

Long “Wait Time” in WordPress

  • # January 5, 2013 at 11:16 pm

    Hey Guys,

    I’m sporadically experiencing some ridiculously long “wait times” (time to first byte) in a number of my wordpress installs. Using pingdom, the waterfall shows that sometimes the wait time before the site even starts loading is upwards of 20+ seconds! It doesn’t happen everytime, but it does happen. Once connected, the site is sufficiently fast to download. It’s happening with a couple of sites:

    http://www.fllegalgroup.com/
    http://www.journey-notes.com/

    I’m using caching, I’ve combined much of my CSS and JS… “Loading” is not my issue. It’s the wait time / ttfb that I am looking to address. All of the html only sites connect and load great from the same server, so I’m thinking it is a PHP/MySQL issue (WordPress).

    Any help would be greatly appreciated.

    Godspeed,
    Omar

    # January 5, 2013 at 11:45 pm

    The first link loads right away for me. The second has the issue on my end.

    # January 6, 2013 at 12:04 am

    It might be a Javascript error. I get an error in the console only on the homepage and only the homepage is the issue. If I link to this URL: http://www.journey-notes.com/blog, it’s fine.

    Edit: Hmm. I received a 502 error when trying it again. Try disabling all plugins, first to determine if that may be the cause.

    # January 6, 2013 at 3:23 am

    Both sites load slow for me as well, but the latter is especially worse.

    For the first site, based on the source code, it doesn’t look like you’re actually using caching–There’s no cache comment at the end of your source code.

    As for the second site, I see you’re using W3 Total Cache, but it’s not actually caching. You can see this for yourself by loading the page and looking at the source code timestamp at the bottom. Then reload the page, look again, and you’ll find the timestamp update. That means WordPress is generating your pages from scratch every time. Unless you know you need it, you may want to turn off object caching. Just using the disk enhanced/basic page caching should be sufficient for most sites. Make sure W3TC is able to write to your .htaccess file as “disk enhanced” caching uses .htaccess mod_rewrite rules, while the simpler “disk basic” caching does not use rewrite. Try switching to basic caching to see if that makes a difference. You’ll have to check the source code timestamp to see if it’s working properly.

    You may want to post this on the W3 Total Cache support forum. The recent update of a few days ago (v0.9.2.5) seems to have given some folks some difficulty with their caching. Some have reported their site slowing down since then. You also may want to try WP Super Cache as an alternative:
    http://wordpress.org/extend/plugins/wp-super-cache/

    With all that said, without knowing what other plugins you have installed, it’s hard to say what the issue is. It may another plugin causing this.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".