Grow your CSS skills. Land your dream job.

Anchor not working

  • # January 8, 2013 at 1:16 pm

    I have a [one page site](http://www.articulate.uk.com/temp/ “”) which uses anchors to navigate to the various sections. It all works fine except when the contact form is submitted, with either valid or invalid data, the page repositions to the section just above the contact form.

    I’ve tried setting the form action to #contactAnchor and index.php#contactAnchor and neither works correctly. Any suggestions? thanks!

    # January 8, 2013 at 1:20 pm

    Well, when you try to submit it with nothing, it gives you this link: http://www.articulate.uk.com/temp/index.php#contactAnchor&panel1-1&panel2-1

    Which keeps the contact page as you’d expect. So maybe try #contactAnchor&panel1-1 or #contactAnchor&panel1-1&panel2-1 if that doesn’t work :)

    # January 8, 2013 at 2:21 pm

    Interesting suggestion, but unfortunately neither option worked. However I have now tested the original code in Chrome which is working but not working in Firefox. Will do some more googling on this but in the meantime… Any other ideas?

    # January 8, 2013 at 6:31 pm

    I’ve tested the site on Firefox, Safari and Chrome and it works fine on Safari and Chrome. If i disable javascript on Firefox then it also works but javascript is essential to the site so does anyone know a workaround? Thanks.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".