Skip to main content

Forums

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • in reply to: PHP multiple table #79834

    nanook
    Member

    I was able to fix the sql statement to get all the information I needed but still need help on getting orders to appear on one line. Its reading every line in the DB as is should, if I have an order 119 and they ordered 4 items its displaying a line for each item that ordered. I’m trying to get it to do this:

    order Item description color
    119 Leash dog lead red
    collar dog collar blue
    120 food dog food
    121 leash dog lead green

    Below is the current working code, can any on lend a hand?

    Thanks,
    TIm

    <?php
    // { initialise variables
    $amt=10000;
    $start=0;
    // }
    // { connect to database
    function dbRow($sql){
    $q=mysql_query($sql);
    $r=mysql_fetch_array($q);
    return $r;
    }
    function dbAll($sql){
    $q=mysql_query($sql);
    while($r=mysql_fetch_array($q))$rs[]=$r;
    return $rs;
    }
    mysql_connect(‘localhost’,’root’,’vai0316′);
    mysql_select_db(‘barksand_barks’);
    // }
    // { count existing records
    $r=dbRow(‘select count(OrderID) as c from orders’);
    $total_records=$r;
    // }
    // { start displaying records
    echo ‘{"iTotalRecords":’.$total_records.’,
    "iTotalDisplayRecords":’.$total_records.’,
    "aaData":[‘;
    $rs=dbAll("select * from orders, orderdetails where orderdetails.DetailOrderID = orders.OrderID ");
    $f=0;
    foreach($rs as $r){
    if($f++) echo ‘,’;
    echo ‘["’,$r[‘OrderID’],’",
    "’,$r,’",
    "’,$r,’",
    "’,$r,’",
    "’,$r,’"]’;

    }
    echo ‘]}’;
    // }

    in reply to: animate problem #74598

    nanook
    Member

    Never mind, forgive my ignorance…. a little RTFM goes a long way…..

    Tim

    in reply to: jquery menu problems #66477

    nanook
    Member

    I took out the jquery corners code out and the menu is now working, not sure why that would keep the menu from fully expanding.

    in reply to: jquery menu problems #66465

    nanook
    Member

    Its still not working been taking apart the menu piece by piece but no dice

    in reply to: jquery not working correctly on ie 7 and 8 #65517

    nanook
    Member

    Thanks Locke,

    I’m using the original CSS and downloaded the compressed version of prettyPhoto however it still for some reason does not like IE. Not sure where else to go from here as it should work…. Then again we are dealing with a Microsoft product. :)

    Tim

    in reply to: jquery not working correctly on ie 7 and 8 #65483

    nanook
    Member

    Crap sorry man its been a crazy day… here is the correct link

    http://www.barksandbones.com/dev2/bnb-timberwolf.php

    Thanks

    in reply to: css positioning #65158

    nanook
    Member

    Sweet! Thanks I will give it a try!

    Tim

    in reply to: css positioning #65153

    nanook
    Member

    Yes two column, unless I set the top margin to negative px I can’t get it to align next to the div on the left. I’ve floated it and can’t get it to line up.

    Thanks,
    Tim

    in reply to: jquery/ajax and multipl div’s #58696

    nanook
    Member

    Thanks Rob!! It work perfect! For anyone else that’s learning jquery this is what I did. Thanks again Rob!

    <script type="text/javascript">
    $(function(){
    $(‘li a’).click(function(){
    id=$(this).attr(‘id’);
    $("#content").load("pages.php?o="+id+"");
    return false;
    });
    $(‘li a’).click(function(){
    id=$(this).attr(‘id’);
    $("#extra").load("images.php?o="+id+"");
    return false;
    });
    });

    in reply to: browser fun #51441

    nanook
    Member

    Also is there a better layout for this? When I resize the browser the content and images slide all over the place. Obviously this is my first attempt at CSS an would really like to do it correctly and am open to any ideas.

    Updated links:

    http://howsmykiddriving.org/dev
    http://howsmykiddriving.org/dev/aboutus.php

    Thanks,
    Tim

    in reply to: browser fun #51351

    nanook
    Member

    Sorry guys if you want to have a look I had to move everything to http://howsmykiddriving.org/dev. Sorry for the confusion but I wanted to get it out of the production and into dev where it should be till its done.

    Tim

    in reply to: browser fun #51348

    nanook
    Member

    Thanks, I know its in FF its in all the others except IE. The pages are not done as they are still in development, thanks for the information as I probably should have two even columns. Any ideas on the black lines? Also what is the layout for the columns for this so there is not a lot of barren space?

    Thanks,
    Tim

    in reply to: repeating image issue #51403

    nanook
    Member

    That did the trick, thanks! That was pretty easy not sure why I did not see that….

    in reply to: repeating image issue #51401

    nanook
    Member

    Crap, sorry guys… I’m still asleep :oops:

    http://howsmykiddriving.org

    in reply to: Background problem? #51358

    nanook
    Member

    I found it, its was a margin issue, thanks guys.

    Tim

Viewing 15 posts - 1 through 15 (of 18 total)
icon-link icon-logo-star icon-search icon-star