Forums

Give help. Get help.

  • deb
    # September 27, 2017 at 7:03 pm

    Hello
    Sorry if this is already answered, I have a strange problem. I have redirected from www to non-www. If you do http://www.example.com then it redirects to https://example.com, which seems to work. I have changed all database URL from http to https as well (from Better Search Replace plugin). All seems working.

    The Problem:
    If we hit
    http://www.example.com/wp-content/uploads/2015/07/abc.jpg (this still loads and it does not redirect to https), if we put https, it still works, if we even to http only without www, it redirects to https but only problem is if we put http://www.example.com/wp-content/uploads/2015/07/abc.jpg then it does not redirect.

    on wp-config I have define siteurl and home as https://example.com.
    My htaccess:
    `

    BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    RewriteCond %{HTTPS} =off [OR]
    RewriteCond %{HTTP_HOST} !^example.com$
    RewriteRule ^(.*)$ “https://example.com/$1” [R=301,L]

    END WordPress

    Options -Indexes
    `

    Thank you,
    Deb

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

icon-anchoricon-closeicon-emailicon-linkicon-logo-staricon-menuicon-nav-guideicon-searchicon-staricon-tag