Treehouse: Grow your CSS skills. Land your dream job.

WP: Can’t attach Featured Image

  • # July 27, 2012 at 7:15 pm

    I’m trying to attach a featured image to a post, but after I click the “Use as Featured Image” button, it changes to “saving” and then just stays there.

    Normally it only takes a second or so.

    I’ve looked into memory issues but that doesn’t seem to be the issue. Is there anything else that seems to cause this?

    I’m testing on the basic 2011 theme and no plugins.

    # July 27, 2012 at 7:24 pm

    any javascript errors?

    # July 27, 2012 at 8:17 pm

    Chrome is giving me this. I’m not sure how to interpret it:

    POST *website*/wp-admin/admin-ajax.php  load-scripts.php:4 load-scripts.php:4
    f.extend.ajax load-scripts.php:4
    f.each.f.(anonymous function) load-scripts.php:4
    WPSetAsThumbnail load-scripts.php:6
    # July 27, 2012 at 8:46 pm

    Definitely some kind of ajax error but I have no idea what I need to do to fix it

    # July 31, 2012 at 12:33 pm

    Any idea?

    # July 31, 2012 at 12:46 pm

    Hey Noah. No idea what that problem is caused by :s Never seen that before. Have you tried asking on the WordPress forums?

    # August 22, 2012 at 11:25 pm

    I’m in trouble with this error too. Until now I discover that ngggallery last version add some options in wp-settings-{userid} cookie. After remove ngg the cookie remains (several entries in WP database refers to ngg after remove). In Chrome developer tools if you delete the cookie
    (Resources->Cookies->{yourdomain}) you can set and remove post thumbnail again. I have several plugins and this can cause a “plugin hell”. But in my tests I installed a new version just with WP (post thumbnail ok) after install last version of ngggallery no more post thumbnail. After remove ngggallery the problem remains. No other plugins in my test site. I’m trying remove the creation of things like ‘imgsize=thumbnail&align=none&ngg_show_update_notice196=1&ngg_upload_resize=1‘ that remains after ngggallery install. See your {prefix}_postmeta table and search for records with ‘ngg’. If you have new information about this problem, please share the news.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.