Give help. Get help.

  • # February 22, 2012 at 4:35 pm

    Hi guys,

    I’ve just started developing a site in Twitter Bootstrap and got a couple of quick questions.

    You can see the site here and I was wondering why the Javascript Carousel isn’t showing? When I check the code in firebug the whole section is faded out.

    Can anyone tell me where I am going wrong? The instructions for implementing the Carousel are here.

    I wasn’t sure how to “call” via javascript using $(‘.carousel’).carousel(). Perhaps this is the problem???

    Also, I’ve added my company logo to the navbar, but ideally I want this to sit above the navbar. I tried simply adding a new div above which contained the logo but I could get it to show. Can anyone advise on how I would do this?

    Any help would be much appreciated.



    # February 22, 2012 at 4:47 pm

    The URL of your images are wrong.

    Should be:

    Not sure if that will fix your problem entirely, but start there.

    # February 22, 2012 at 5:06 pm

    Thanks Senff, I’ve taken out the ‘/img’ before the url’s but unfortunately that didn’t work. Any other ideas?

    # February 22, 2012 at 5:43 pm

    None of your JS files are loading – are they are your server?

    # February 23, 2012 at 8:44 am

    I have a ‘js’ folder in the website directory that contains the ‘bootstrap-carousel.js’ file. However it doesn’t seem to be linking to it. I’m not sure what I am doing wrong. It’s probably something quite straight forward, but I can’t figure it out.


    # February 23, 2012 at 10:46 am

    Well obviously you need to call the JS then.

    Try adding this inside your head tag.

    # February 23, 2012 at 11:11 am

    You’re probably calling the JS files in the wrong folder, or you have them misplaced.

    At the end of your code, you’re calling all the JS files like this:

    etc. etc.

    However, those files can not be found:
    etc. etc, they all give 404 errors.

    I checked in the root folder, but they’re also not there:

    So basically, just make sure you have placed all the JS files in the right location, and then call them using the proper path.

    # February 23, 2012 at 12:26 pm

    Hmm… the files are definitely there but as I’m working on the site in Coda on my machine. I think it’s to do with the way that I am linking to them. The links like this below just don’t work.

    I’m sure it’s something quite straight forward. If anyone has a chance to look it may help by looking at the download files for Twitter Bootstrap, as I haven’t edited them much at all yet.

    Hope someone can help me find a solution.



    # February 23, 2012 at 1:29 pm

    When you say the files are definitely there…they are definitely WHERE? Cause if you follow any of the links I posted in my previous post, you’ll see that they’re definitely not there.

    (Unless they are, but made hidden/unaccessible/secret.)

    # February 23, 2012 at 7:01 pm

    Figured it out. I had installed the bootstrap-carousel.js plug-in thinking that’s all I needed, but I hadn’t installed the other files you mentioned:

    I installed all of the files and now it works. Sorry that it was such as basic mistake, and thanks for helping me out.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.