Forums

The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums Back End SVG not displaying in Image Gallery

  • This topic is empty.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #239167
    irxy
    Participant

    Hi! I’m trying to use some plugins (Add Full SVG, Scalable Vector Graphics) uploading a vectorial SVG file, but displayed in a gallery (default one) and it doesn’t appear. I mean, the svg image appears if you add it in a post as a normal, not as a gallery.

    What can I do?

    Thank you

    #239168
    Paulie_D
    Moderator

    No idea..without a demo of some code I’m not sure how we can help.

    #239172
    irxy
    Participant

    Hi, thanks for your quick answer.

    What do you specifically need? I can provide you the code you need.

    #239184
    Paulie_D
    Moderator

    How would I know what code?

    You need to replicate the issue, ideally in a Codepen.io demo with just enough of your code to demonstrate the problem.

    #239185
    irxy
    Participant

    The problem is that I can not add SVG files to a any normal/default gallery (not displayed). I’m not programmer and I don’t know where to search the code to show you just that question, and less how to do a demo. Excuse my ignorance. But actually, I dont think you need a demo to understand that question. I think the problem is that WordPress resizes images and uses those generated files for the gallery (vectorial images are blurry). I mean, it’s a general problem with WordPress.
    That’s why I was looking for a plugin which allows to show SVG files in galleries.

    I’m using Expositio Theme, working in local, and in the child theme.

    #239202
    Paulie_D
    Moderator

    oh…so it’s not a CSS issue, it’s a WP one.

    Moving.

    #239207
    irxy
    Participant

    Thank you for moving the post to the correct place.

    Does anyone have any idea how to solve the problem?
    Thank you!

    #239428
    Alex Zaworski
    Participant

    It sounds like you’re trying to add an SVG to some gallery via a media uploader and it isn’t appearing in the list of files? Hard to tell for sure. If that’s the case, my assumption is that whatever gallery you’re using doesn’t support the format. One option might be converting to a non-svg file type.

    #239431
    irxy
    Participant

    Hi,
    I’m trying to add a SVG image to a image gallery and it can not be displayed. I understand it’s not possible to do it from a gallery. Then I would like to do another thing (a temporal path till that will be possible).

    I would like to add a SVG image (not as a gallery, just as an image added in a post). I can do it with some pluggin (that’s not the problem). But for do that, I have to remove the text width (in some concrete posts, not in all the posts) to add an image with full width (original width image) and do horizontal scroll (it would look like a gallery). Maybe it’s not the best way to do that, but I can not find another way to do it.

    The theme resize the images (as default in galleries) fixing the height and resizing the width. I want to have the same as in galleries but adding a normal image in a post.

    I need a vectorial format because it’s a vectorial image, that’s the thing…

    How should I do it?

    Thank you for your answer and I hope you understand this mess… :)

    #239442
    Shikkediel
    Participant

    One option might be converting to a non-svg file type.

    You could do this with Inkscape which is free and export the svg to a png image. Hard to say anything else based on the current amount of info and lack of demo.

    #239443
    irxy
    Participant

    Thank you for your answer, but I already did and the image lose a lot of quality, even in PNG saved for web. I have to find another option.

    Anyway, thanks for your answer.

    #239502
    Alex Zaworski
    Participant

    The image shouldn’t lose much quality at all if correctly saved as a png. It won’t be as crisp, but it should definitely be passable. Can you share the image?

    #239608
    irxy
    Participant

    Hi! I think I find the problem. I was trying to put an image really really horitzontal (like 10:2 proportion) and it was bad displayed (resized), but with a normal proportion (1/1, 4/3,…) the quality is better in png, so I can use it even if it’s not SVG.
    Anyway, I would like to use SVG images in galleries, one day.

    Thanks for all.

Viewing 13 posts - 1 through 13 (of 13 total)
  • The forum ‘Back End’ is closed to new topics and replies.