Skip to main content

Forums

This topic contains 1 reply, has 1 voice, and was last updated by  chrisburton 4 years, 7 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #184787

    chrisburton
    Participant

    So I was initially trying to install HHVM but something went wrong and now when I try sudo yum update, I receive the following issue:

    Loaded plugins: fastestmirror
    Determining fastest mirrors
    epel/metalink                                            |  16 kB     00:00     
     * base: ftpmirror.your.org
     * epel: mirror.es.its.nyu.edu
     * extras: ftpmirror.your.org
     * updates: ftpmirror.your.org
     * webtatic: us-east.repo.webtatic.com
    base                                                     | 3.7 kB     00:00     
    base/primary_db                                          | 4.4 MB     00:07     
    epel                                                     | 4.4 kB     00:00     
    epel/primary_db                                          | 6.3 MB     00:00     
    extras                                                   | 3.3 kB     00:00     
    extras/primary_db                                        |  19 kB     00:00     
    hhvm                                                     | 3.0 kB     00:00     
    hhvm/primary_db                                          |  66 kB     00:00     
    mariadb                                                  | 1.9 kB     00:00     
    mariadb/primary_db                                       |  18 kB     00:00     
    updates                                                  | 3.4 kB     00:00     
    updates/primary_db                                       | 5.3 MB     00:34     
    vz-base                                                  |  951 B     00:00     
    vz-base/primary                                          | 1.3 kB     00:00     
    vz-base                                                                     3/3
    vz-updates                                               |  951 B     00:00     
    vz-updates/primary                                       | 2.2 kB     00:00     
    vz-updates                                                                  8/8
    webtatic                                                 | 3.6 kB     00:00     
    webtatic/primary_db                                      | 216 kB     00:00     
    Setting up Update Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package binutils.x86_64 0:2.20.51.0.2-5.36.el6 will be updated
    ---> Package binutils.x86_64 0:2.20.51.0.2-23.el6 will be an update
    ---> Package curl.x86_64 0:7.19.7-37.el6_5.3 will be updated
    ---> Package curl.x86_64 0:7.29.0-13.el6 will be an update
    ---> Package gmp.x86_64 0:4.3.1-7.el6_2.2 will be updated
    ---> Package gmp.x86_64 0:4.3.2-1.el6 will be an update
    ---> Package libcurl.x86_64 0:7.19.7-37.el6_5.3 will be updated
    ---> Package libcurl.x86_64 0:7.29.0-13.el6 will be an update
    ---> Package libgcc.x86_64 0:4.4.7-4.el6 will be updated
    ---> Package libgcc.x86_64 0:4.7.2-8.el6 will be an update
    ---> Package libgomp.x86_64 0:4.4.7-4.el6 will be updated
    ---> Package libgomp.x86_64 0:4.7.2-8.el6 will be an update
    ---> Package libstdc++.x86_64 0:4.4.7-4.el6 will be updated
    ---> Package libstdc++.x86_64 0:4.7.2-8.el6 will be an update
    ---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be updated
    ---> Package libtool-ltdl.x86_64 0:2.2.6-15.8.el6 will be an update
    ---> Package rpm.x86_64 0:4.8.0-37.el6 will be updated
    ---> Package rpm.x86_64 0:4.9.1.3-6.el6 will be an update
    --> Processing Dependency: libdb-5.2.so()(64bit) for package: rpm-4.9.1.3-6.el6.x86_64
    ---> Package rpm-libs.x86_64 0:4.8.0-37.el6 will be updated
    --> Processing Dependency: librpm.so.1()(64bit) for package: 1:net-snmp-libs-5.5-49.el6_5.3.x86_64
    --> Processing Dependency: librpm.so.1()(64bit) for package: 1:net-snmp-5.5-49.el6_5.3.x86_64
    --> Processing Dependency: librpmio.so.1()(64bit) for package: 1:net-snmp-libs-5.5-49.el6_5.3.x86_64
    --> Processing Dependency: librpmio.so.1()(64bit) for package: 1:net-snmp-5.5-49.el6_5.3.x86_64
    ---> Package rpm-libs.x86_64 0:4.9.1.3-6.el6 will be an update
    ---> Package rpm-python.x86_64 0:4.8.0-37.el6 will be updated
    ---> Package rpm-python.x86_64 0:4.9.1.3-6.el6 will be an update
    --> Processing Dependency: librpmbuild.so.2()(64bit) for package: rpm-python-4.9.1.3-6.el6.x86_64
    --> Processing Dependency: librpmsign.so.0()(64bit) for package: rpm-python-4.9.1.3-6.el6.x86_64
    --> Running transaction check
    ---> Package libdb.x86_64 0:5.2.36-1.el6 will be installed
    ---> Package rpm-build-libs.x86_64 0:4.9.1.3-6.el6 will be installed
    ---> Package rpm-libs.x86_64 0:4.8.0-37.el6 will be updated
    --> Processing Dependency: librpm.so.1()(64bit) for package: 1:net-snmp-libs-5.5-49.el6_5.3.x86_64
    --> Processing Dependency: librpm.so.1()(64bit) for package: 1:net-snmp-5.5-49.el6_5.3.x86_64
    --> Processing Dependency: librpmio.so.1()(64bit) for package: 1:net-snmp-libs-5.5-49.el6_5.3.x86_64
    --> Processing Dependency: librpmio.so.1()(64bit) for package: 1:net-snmp-5.5-49.el6_5.3.x86_64
    --> Finished Dependency Resolution
    Error: Package: 1:net-snmp-5.5-49.el6_5.3.x86_64 (@updates)
               Requires: librpm.so.1()(64bit)
               Removing: rpm-libs-4.8.0-37.el6.x86_64 (installed)
                   librpm.so.1()(64bit)
               Updated By: rpm-libs-4.9.1.3-6.el6.x86_64 (hhvm)
                   Not found
    Error: Package: 1:net-snmp-5.5-49.el6_5.3.x86_64 (@updates)
               Requires: librpmio.so.1()(64bit)
               Removing: rpm-libs-4.8.0-37.el6.x86_64 (installed)
                   librpmio.so.1()(64bit)
               Updated By: rpm-libs-4.9.1.3-6.el6.x86_64 (hhvm)
                   Not found
    Error: Package: 1:net-snmp-libs-5.5-49.el6_5.3.x86_64 (@updates)
               Requires: librpmio.so.1()(64bit)
               Removing: rpm-libs-4.8.0-37.el6.x86_64 (installed)
                   librpmio.so.1()(64bit)
               Updated By: rpm-libs-4.9.1.3-6.el6.x86_64 (hhvm)
                   Not found
    Error: Package: 1:net-snmp-libs-5.5-49.el6_5.3.x86_64 (@updates)
               Requires: librpm.so.1()(64bit)
               Removing: rpm-libs-4.8.0-37.el6.x86_64 (installed)
                   librpm.so.1()(64bit)
               Updated By: rpm-libs-4.9.1.3-6.el6.x86_64 (hhvm)
                   Not found
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    
    #184820

    chrisburton
    Participant

    Removing hhvm.repo from /etc/yum.repos.d solved it.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

icon-link icon-logo-star icon-search icon-star