The Lodge is members-only design/dev videos and Office Hours.

Next Office Hours Session: "Implementing an SVG Icon System" Nov 30 - 6:00 PM Eastern

Strange behaviour Jquery

  • # May 19, 2009 at 3:32 am

    I’ve got two problems using script and a man’s best friend (google) can’t give me an answer.

    Problem 1:

    This gives an error in firebug: $ not defined


    But when I use the next lines of code, it does


    I can get it defined but why doesn’t it work like it should and like it works on all the other sites?

    Problem 2:

    The following just doesn’t do anything

    # May 19, 2009 at 5:22 am

    Wordpress uses a couple of other javascript libraries as well as jQuery and they also use the $ sign. So you have a conflict going on.
    I always use the google hosted version of jQuery thus:


    But if you want to use the version bundled with WordPress you can use this line:

    < ?php wp_enqueue_script(jquery); ?>

    And as regards the conflict, change $ to ‘jQuery’ so you would have:

    # May 19, 2009 at 2:42 pm

    Still no success

    < ?php wp_enqueue_script(jquery); ?>

    this now gives me "Jquery not defined" so still the same error.

    When i put


    I don’t get the error but the script doesn’t do anything. When i’m learning something i try to do stuff myself instead of copy-paste from other sites. But even a copy-paste from the original site doesn’t do anything

    # May 19, 2009 at 3:15 pm

    First thing I notice is


    should be


    and the second thing is the path to your image. I’m guessing it is in with your theme files so the path should look something like this:

    ‘< ?php bloginfo('template_directory'); ?>/images/affiches/event_small.png’
    # May 21, 2009 at 3:48 am

    If you give a SCRIPT element a SRC then any code residing within it will NOT run. You have to include two SCRIPT elements; one to get jQuery and another for your code:


    # May 23, 2009 at 2:46 pm

    I finally found the problem.

    The problem wasn’t the function I called, but when I called it:

    < ?php wp_enqueue_script('innerfade', '', array('jquery') ); ?>

    < ?php wp_head(); ?>

    I have to "wp_enqueue" the script before <?php wp_head(); ?> and the script itself has to come after <?php wp_head(); ?> I placed everything above <?php wp_head(); ?>

    Spent hours and hours on this and I can’t believe it was something so small like this. But it makes sense

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

There's a whole bunch of content on CSS-Tricks.

Search for Stuff   •   Browse the Archives

Get the Newsletter ... or get the RSS feed