Give help. Get help.

  • # January 8, 2011 at 4:36 pm

    The title of my website is showing twice on every page except my homepage and blog page.

    If I go in the admin panel and take out the Site Title, it just shows something like this
    ” Portfolio | “
    but if I put it back in it shows
    ” PortfolioChristopher Burton | Christopher Burton “

    Any Idea?

    # January 8, 2011 at 5:01 pm

    Did you hardcore part of your title tag in your template?

    # January 8, 2011 at 5:34 pm

    Hehe, Hardcode of course… :-)

    Well, it was pretty obvious aswell, but the first thing I could think of. Can you link your title tag from your template file?

    This should give the result you want;

    < ?php wp_title();?> | < ?php bloginfo('name'); ?>

    It uses the Blog name from your settings page (which would be Christopher Burton, if im not completely off) and the title of the page you are viewing at. When using the above code, you should not write “|” in your title on the page.

    # January 8, 2011 at 5:37 pm

    Actually, this would be more correct:

    < ?php wp_title('|', true, 'right'); bloginfo('name'); ?>
    # January 8, 2011 at 6:18 pm

    I was gonna call it!

    The Yoast SEO Plugin did this to me also.

    I’m only an hour out, that’ll teach me for eating out!

    # March 7, 2012 at 9:55 pm

    Yoast SEO got me with this too

    # April 26, 2012 at 11:49 am

    How I fixed that.
    Went to SEO > Titles in the Dashboard.
    Found Page > Title templates (as I do have pages only on my website)

    And inserted this, but without quotes “%%title%%-“

    Good luck!

    # May 22, 2013 at 7:18 pm

    I also have that same issue and that code hasn’t seemed to change it. Any thoughts? Thanks.

    # May 22, 2013 at 7:24 pm

    @lisapatb Are you using an SEO plugins?

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.