Skip to main content

Forums

The forums ran from 2008-2020 and are now closed and viewable here as an archive.

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #30394
    spunkil
    Participant

    Hi,
    I have a menu and the last list item is a flag to change the language to English.
    I tried to prevent hovering effect on it but with no success.

    My web site – http://www.soniagarcia.co.il

    The link item is:




  • And in the style.css I tried a few things, but none of them helped:

    #suckerfishnav ul li.qtrans_flag,
    #suckerfishnav ul li.qtrans_flag a:hover,
    #suckerfishnav ul li.qtrans_flag a.noback{
    display:block;
    height:12px;
    width:18px;
    border:1px solid #B6B6B6;
    background: none;
    }

    #suckerfishnav ul li.qtrans_flag a:hover {
    background: none;
    }

    #trans_flag_link a:hover {background:none;}
    a#trans_flag_link:hover {background:none;}

    Do you know what I should do?
    Thanks!

    #78994
    virtual
    Participant

    Give it a class and do not put the a:hover on that particular class in the css. It will still be a link, just won’t have a hover effect.

    #78995
    spunkil
    Participant

    I created a class

    And on the css I did

    .trans_flag_link {background:none;}

    but no good...
    it inherits the hover from the menu..

    #78997
    virtual
    Participant

    It’s showing a dull blue, if you are not using this colour anywhere in your site, go to the Suckerfish style sheet and find this line, second from bottom

    #suckerfishnav li:hover, #suckerfishnav li.sfhover {background:#5E7AD3;}

    and remove it. If you are using it on your site you will need to add in the li with the class for the flag to change the background on hover to show the flag.

    #78868
    spunkil
    Participant

    Hmm..
    I changed it to #suckerfishnav li:hover, #suckerfishnav li.sfhover {background:none;}
    So – now something else is blocking it when hovering on it?

    #78869
    Joshee23
    Member

    It’s showing a dull blue, if you are not using this colour anywhere in your site, go to the Suckerfish style sheet and find this line, second from bottom..
    thanks,,http://howtodealwithdepression.org/

    #78870
    spunkil
    Participant

    Ok, I think it’s finnaly good, I changed that line to background-color: transparent and it doesn’t show anymore
    Thanks a lot!

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘CSS’ is closed to new topics and replies.