The Lodge is members-only design/dev videos and Office Hours.

Next Office Hours Session: "Implementing an SVG Icon System" Nov 30 - 6:00 PM Eastern

[Solved] Extra HTML in my page

  • # November 2, 2009 at 10:25 pm


    WordPress is adding extra <p> tags in my code. I’m using the HTML tab to paste the code.

    Here’s what’s happening:


    See the extra <p>’s?

    It’s not a plugin, I don’t have any plugin installed at all.

    I have already taken out all the spaces between the HTML tags (something I shouldn’t have to do at all) and out of 6/7 HTML errors I had only 1 error remains (I can fix one of the <p>’s you see above, but I left both to show the kind error I’m getting).

    I’ve searched the forums before posting but I didn’t find anything related to my problem.

    This is very disappointing, although I’m not new to HTML this is my first time using WordPress to build a website because I heard very good comments about it, but now I’m trying such a simple thing which is copy HTML code from Dreamweaver to the HTML tab in WordPress and WordPress welcomes me with this absurd problem.

    If there’s no way to solve this, I will have to dump WordPress for another CMS. I honestly do NOT want to do it, but seems I’m being forced to do so.

    Thanks for any help you can provide on this issue.

    # November 3, 2009 at 3:18 am

    It looks like it’s probably a problem in the template itself. You don’t mention anything about the templates, so I assume you haven’t checked them?

    Is the slider what you’re adding to a page? If it is, the slider should probably just be created on a separate template.

    # November 3, 2009 at 11:10 am

    You might also try:

    Although then when you DO want paragraph tags, you’ll need to add them.

    # November 3, 2009 at 7:06 pm

    Chris, I was actually going to contact you directly ( :D ) about this problem, but I solved it already.

    And yes, installing the Disable WPAUTOP plugin worked perfectly, the people at suggested it to me.

    when you DO want paragraph tags, you’ll need to add them.

    Totally what I want.

    Thanks for your help guys.

    Ricardo Zea.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

There's a whole bunch of content on CSS-Tricks.

Search for Stuff   •   Browse the Archives

Get the Newsletter ... or get the RSS feed