The Lodge is members-only design/dev videos and Office Hours.

Next Office Hours Session: "Programming Fundamentals" Dec 02 - 2:00 PM Eastern

[Solved] Alignment issue in IE

  • # December 22, 2010 at 4:54 pm

    Hey guys, I’m having some layout issues with this site I’m finishing up.
    The issues are only in IE8 compatibility mode (i have IE 8 running on pc).

    Any help would be very appreciated.

    # December 22, 2010 at 5:29 pm

    This reply has been reported for inappropriate content.

    You need to validate your site, you have both html and css errors. Notably

    You can only use an id once on the page and it is more common to find the id tag on the ul not on each li tag, then you can target your li tags by using ul#nav li
    For the navigation, float your li tags left and for the text being pushed down, float the article image.

    # December 22, 2010 at 9:52 pm

    Thanks for the response.

    Fixed the validation errors and the image float. The nav is still not working though… :(

    # December 22, 2010 at 10:36 pm

    This reply has been reported for inappropriate content.

    You have floated the a tags left not the li tags which are spanning the full width of the ul in IE7 and are consequently being pushed down a line.

    # December 23, 2010 at 8:45 am

    That did it! Thanks so much for your help, i would of never found that.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

There's a whole bunch of content on CSS-Tricks.

Search for Stuff   •   Browse the Archives

Get the Newsletter ... or get the RSS feed