The Lodge is members-only design/dev videos and Office Hours.

Next Office Hours Session: "Implementing an SVG Icon System" Nov 30 - 6:00 PM Eastern

Sharing a link on Facebook: No Thumbnail

  • # July 4, 2013 at 8:45 pm

    Hi there,

    Quite stumped. I Googled and did various things that people have told me to do, but nothing is working. I have several WordPress sites and whenever I try to post them on Facebook, no thumbnail image appears.

    For example, if you share this link on Facebook, no thumbnail is being generated:


    # July 4, 2013 at 9:38 pm

    Facebook uses Open Graph for all of its thumbnail gathering. I don’t see any og meta tags on the site that you linked to. This should have all of the info to get you started:

    # July 4, 2013 at 10:11 pm

    I’d like to add that in case there are no OG Meta tags on a site, Facebook tries to grab an image from the page. However, the page you list does not contain any images, at least not IMG tags — only background images, and Facebook ignores those for thumbnail gathering.

    # July 11, 2013 at 4:41 pm

    Strange… I tried both techniques and neither worked. I put in the OG Meta Tags as well as put in an IMG and just position:absolute/left:-9999px; it out of the way. Help?

    # July 11, 2013 at 4:47 pm

    The Facebook debugger should help you here:

    # July 11, 2013 at 5:14 pm

    Thank you!

    Looks like it did work. I guess it takes longer on my computer or something, but it worked for my boss’! Thank you!

    # July 11, 2013 at 5:57 pm

    Yea, it’s definitely not instant, I should have mentioned that. Glad you got it sorted!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

There's a whole bunch of content on CSS-Tricks.

Search for Stuff   •   Browse the Archives

Get the Newsletter ... or get the RSS feed