Treehouse: Grow your CSS skills. Land your dream job.

Scroll Right to Empty White Space

  • # August 15, 2012 at 12:34 pm

    I’m cleaning up a site and I think I might have met my match. Everything is fine when you are viewing the webpage upon the load of the page. However, if you happen to scroll to the right there is a massive valley of white space. I’ve looked through these discussions and a lot of people recommend setting a min-width and things like that. I’m trying to clean up the author’s css as best I can. I’ve currently added a min-width of 960 (the content area). The wrappers for all the main elements are set to 100%. The site is synched over 2 servers. The main version that is mirrored can be found

    # August 15, 2012 at 2:24 pm

    There’s something funky going on with the position:relative properties on body.home and body. If I turn them both off, the whitespace goes away.

    Unless you are planning on actually adjusting the position of the don’t need them…much like all those width:100% declarations I kept seeing.

    # August 15, 2012 at 3:22 pm

    I’ve gone through and eliminated those unnecessary rules, and the problem is solved for a large portion of the people viewing the page. However, the problem is still present within Firefox. Thanks Paulie for the help so far, I appreciate it.

    # August 16, 2012 at 5:11 am

    Struggling with FF but there are a number of issues which come up when you validate:

    Most of these are unimportant but you might want to look into some to see if FF just doesn’t like it.

    # August 16, 2012 at 6:52 am

    AHA! …..It’s not in the HTML or CSS…it’s something in the JS.

    In FF user the Web Developer Toolbar and disable Javascript and the scrollbar goes away after reloading the page

    Tracking down what all that JS in your page is doing is another matter and beyond my expertise.

    # August 16, 2012 at 1:29 pm

    Thanks so much Paulie. I guess I’ll have to start digging through the Javascript.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.