The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums Back End Problems with WordPress when using PHP5

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #28999

    I run several client sites on my server and they all use WordPress to manage content. Recently I tried installing a plugin on a client site and got an error saying I needed PHP5 to run the plugin. I visited my cpanel and discovered my account was still set to PHP4. I switched over to PHP5 (which in turn affected ALL the sites on my server) and proceeded to try to install the same plugin again.

    The problem, is this time, when I tried to install it from the WP interface, it asked me for my FTP information – it never did that before. Also, I’ve found that when using PHP5, I get an error for a lot of plugins saying they don’t have a valid header.

    Can anyone offer some advise, assistance or guidance on what could be causing this? If you need more information, just ask.

    Appreciate it

    Rob MacKay

    hmmm then only thing I can think of, off the top of my head is that when wordpress installs itself and its settings there are some settings designed for PHP4 and some for 5….

    changing PHP version really shouldn’t cause any issues at all as PHP5 is backwards compatible with most of 4’s features – the issues normally come when you use a PHP5 app with PHP4.

    You might have to add FTP details because of the way PHP5 is set up on your server/security settings – I have to do that although I have never looking into why.

    Can you give us the exact errors?


    Hi Rob,

    The fact that PHP5 should be backwards compatible is what’s boggling my mind with this! I did a fair bit of research, and even every blog I visited, including the WordPress codex says "Do yourself a favor, and switch to PHP5" But right now PHP5 is giving me more headaches than not – some plugins ONLY work on PHP5. Here’s what I get when I try to install a plugin using the WP interface on PHP5.

    After finding the plugin and clicking "install now" it take me to this screen where I have to enter my FTP information

    I don’t have to enter that when using PHP4.

    So I enter the FTP information, and wait an ungodly amount of time for it to do its thing, only to be met with THIS screen

    At least that’s what I’m getting today. Yesterday, after the upload was done I would get a "This plugin does not have a valid header" message.

    Can anyone please help??

    *EDIT:* I just realized when looking at that image, that it tried to upload the plugin the "public_html/home" which isn’t the folder that the version of wordpress is installed in that this screenshot was taken from!! THIS site is in "public_html/ept" so why is it uploading to /home??

    Rob MacKay
Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Back End’ is closed to new topics and replies.