Forums

The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums CSS PLEASE HELP!…@fontface not working with GoDaddy

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #29568
    Lynz
    Member

    Hopefully someone can figure out the problem here. I have 2 issues:

    1) This is the bigger issue: I have been using @fontface to import some fonts on a site I am building. I set up a test site through my school’s server, and the fonts seemed to be showing fine. Now, I have started uploading the site to the client’s server, which is hosted through GoDaddy, and BOOM,… none of the fonts show up. So then I uploaded the files to my own website, using Globat hosting, and again, they show up fine, so it definitely seems to be a problem with GoDaddy. Is there some sort of compatibility issue with GoDaddy? Has anyone ever experienced this? My client is currently using the hosting that comes free with the domain purchase, and I am trying to convince her to upgrade to a paid plan (if, for no other reason, than to get rid of the giant GoDaddy banner ad at the top of the page). Could this problem possibly have to do with the fact that this is a free version of the hosting?

    Here are links so hopefully people can see what I mean:
    The original test site (in which the fonts seem to work fine): http://lls244.aisites.com/ESC/
    The second test site (set up using MY hosting @ Globat, didn’t bother to upload images for this one, but fonts are there and seem to work): http://www.exhibit-z.com/test/index.html
    And finally the GoDaddy hosted site (no fonts at all, wtf?): http://www.escforthearts.com/

    All three of these sites have exactly the same files uploaded.

    Here is a screenshot of what the fonts SHOULD look like (in case I have more issues than I thought, and they are not showing up at all).[attachment=0]ESC-Screenshot.jpg[/attachment]

    2) I have tried all sorts of different variants in the CSS, but it seems that NO version of IE (not 6, 7, or 8) is displaying the fonts at all. (I am on a mac, but using Adobe Browser Lab to preview the site in different browsers.) They seem to display fine with the latest versions of Firefox and Safari.

    I am still a student, so maybe I am just making some stupid mistake here… SOMEONE PLEASE HELP!

    Thanks,
    Lynsey

    #80638
    angelfish276
    Participant

    I just ran into the same problem. I wish I had an answer to post but all I have is another cry for help.

    #80630
    virtual
    Participant
    #74454
    edac2
    Member

    Same problem here. Identical files on staging site with MediaTemple, but as soon as I went live on client’s GoDaddy space, no embedded fonts. I have another site on GoDaddy where the embedded font does work (http://www.corgentum.com), so I’m wondering if the problem is unique to a specific server.

    #73537
    edac2
    Member

    I got @fontface to work! All I changed was to put the “name” of the font in double quotes, even though the font I was using is a single word. Go figure.

    #74942

    Same problem here :( tried double quotes – didn’t help. Any resolution on this for anyone else?

    #106062
    CSS_Bag
    Member

    I was having the same trouble. I moved a client site from one provider to the “Economy” web hosting plan, Linux-based server that GoDaddy provides to people who purchase domain names through them. This was at the client’s request.

    I tried @edac2’s suggestion by replacing the single quote with double quotes for the font names in the @font-face font-family: attribute, but it did not work. I was stumped: I have multiple client sites through GoDaddy, but this is the first time I’ve ever had this happen.

    I ended up moving all of the fonts into the same directory as the stylesheet that references them. So instead of src:url(‘/fonts/webfont.otf’) my stylesheet had to be updated to read src:url(‘fonts/webfont.otf’). I’m wasn’t sure why this seemed to work, but it did.

    Once the fonts were working again, I dug in a little deeper and discovered that the permissions for the original ‘fonts’ folder were all screwed up. In fact, I discovered that several key folders like my ‘javascripts’ folder and a few others that resided outside of my main template folder (this is a WordPress backend) all had wonky permissions. Fixing the permissions on these folders resolved the issues.

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘CSS’ is closed to new topics and replies.