The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums Design PHP form worked on test site, not working now

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #249122

    Hi, all,

    I’m setting up a new website. I’m not a coder — at all. (So, none o’ that fancy talk. Please explain stuff to me like I’m an idiot…’cause on this stuff, I kinda am.)

    Well, I used a website ( to create a form, and it worked great on my test site. (The person who runs the form site doesn’t reply to e-mails for assistance btw.)

    My test site is a domain that I bought and never quite used. You can see it here and even send me a test mail:
    customersstrikeback DOT com (click contact)
    (You’ll notice that the page info does NOT reflect that URL.)

    Well, I took all of the same files and transferred them over to the actual site. I changed the e-mail address and folder references (that I could locate), but the form doesn’t show up. And I cannot figure out why:
    geteditsnow DOT com (click contact)

    And then here’s the strange part:
    Somewhere along the lines, I apparently confused the new form.lib.php with the OLD one. The old .lib.php should read “Your form has been sent. Thank you!,” just like the site does after you’ve hit submit. But the .lib.php reads “Thank you! To send us a follow up or to browse the site again, just RELOAD the page.”

    So, in sum, what the heck have I done and what the !#$!% do I do to fix it?
    Why isn’t the form appearing on GetEditsNow?
    Why isn’t the NEW php info taking hold?

    I’ve put copies of all the files here:
    geteditsnow DOT com/G2G/
    ** NOTE: The index file has a LOT of stuff commented out. This is b/c it was a Template. I at first altered the template’s form quite a bit, but it couldn’t attach files or have a captcha in it, so I ended up using the new form created via the site above.

    I’m also checking with my web host to ensure there’s nothing in the back-end that needs to be altered.

    As you can see by the above, I’m an editor, I’d be happy to perform some copy editing on your site or perhaps something you’re working on in trade for the assistance.

    Thank you!



    but the form doesn’t show up. And I cannot figure out why

    The iframe src says the form should be at so check that this is indeed the place where you uploaded it. Note that file and folder names should match exactly; that goes for letter-case too – e.g. ‘form.php’ is different to ‘Form.php’, etc.

    EDIT: I clicked on the form link above after posting and the form path is correct (the page does indeed exist at the specified src location). In dev tools I edited the src to ‘/20161211-221b/form.php’ and that makes the form visible in the web page – give that a whirl at your side.

    As for PHP errors in functionality or submissions, you should check your error logs for clues. Error logs might be generated automatically in your website root folder, or they might be in a dedicated folder outside of the root. Depending on the host, they might also be accessed via your web host’s control panel.


    Hi, Beverly,

    Thanks for the reply. I’ve checked the error logs — no errors.

    As for the code, yup, as said, I checked all of that.

    The form, it turns out, does appear in IE. But it’s not showing up in my FF browser.

    Any other ideas?



    So the form is working now. I contacted my web host. They wrote back saying this:
    “I have added redirect to your ‘www’ version of website in your .htaccess file.
    Please clear your browser cookies and cache also refresh the page by Ctrl+F5 and try to check your issue now.”

    I assume this means something in .htaccess file read “” rather than “,” but can you please explain to me why it was something they had to do? Also, is it the norm that something like that would have to be fixed?

    I’m also trying to figure out how t do the following; if possible, please tell me how I might fix:
    1. On my phone, there is a LOT of white space after the 2nd and 3rd panels in the learn more section. Looking at the template, I can’t quite see what I’m missing that’s causing that. Any thoughts glancing at the source? (You can find the section be searching for “<!– One –>” [sans quotes])
    2. On my phone, holding the phone vertically, the width of the Costs chart does not fit. How can I make it resize?
    3. There’s a lot of space between my form and the footer. Similar to the above, I don’t see how/where to remove that space. Thoughts? (I tried resizing the iFrame border for the form, and that only removed a small portion of it.)

    Any input would be appreciated. Thank you as always.


Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Design’ is closed to new topics and replies.