Forums

The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums Other OMG, Help me please!

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #35170

    I think this is a php problem. I was taking a course on Lynda about building WP themes. So I installed WAMP and WP on my machine, setup the database for WordPress on phpMyAdmin and gave the root user no password.

    Messed with some setting in WP and then noticed that every other internal link on the WordPress site returned either a ‘403 forbidden’ error or ‘not found’. What have I done wrong?

    I’ve tried everything and NOW I’ve even gotten myself locked out of phpMyAdmin when I changed the root user password to ‘1’ to see if that would help. Now it tells me the mysql denies access when I try to login because I’m not using a password…for the life of me I don’t know where I’m supposed to put one in.

    Anyway that could possibly offer me some assistance—I’d be grateful.

    #90664

    Wow, I’ve done that once, but I’ll try it again. Thank you.

    #90672

    Ok I did that, and I’m no better off…I’m back to the same original problem which is I guess that I cannot get phpMyAdmin to actually save my ‘no password’ on the root user setting. My steps…

    1. installed WAMP
    2. moved the WordPress files into the ‘www’ folder of the WAMP (this is the folder that had the localhost index file.
    3. went into phpMyAdmin and created a WP database
    4. went into user permissions for that database and tried to save the ‘no password’ selection.

    When I did, I get a yellow caution looking icon followed below it by: (SET PASSWORD FOR ‘root’@’localhost’ = ”), but the selection isn’t saved and I still don’t have “permission” when I try to click internal links on the homepage in a browser.

    #90673

    WOW…okay it’s fixed. Although I did not do anything different–but this time it worked. Why would that be?

    #90676
    TheDoc
    Member

    Very odd, but happy that it fixed itself! If you ever need to change your password, just follow these instructions http://www.kirupa.com/forum/showthread.php?279644-How-to-reset-password-in-WAMP-server

    It’s funny, I’m pretty sure I have no password running locally here, but I don’t think I ever checked a box for that to happen.

    #90693
    tobeeornot
    Member

    Are you running from Dreamweaver? If so, I had that problem and it is all about opening the file templates. Try opening the files from your browser only and not from DW. Do not hit ‘Discover’ or you will get the error message.

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘Other’ is closed to new topics and replies.