Skip to main content

Forums

The forums ran from 2008-2020 and are now closed and viewable here as an archive.

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #22708
    adhoc01
    Participant

    Hi,
    This is my first in depth delve into the world of css, before I have always used it sparingly alongside tables and a heap of php. So I have been using this site as a bible and its going good. HOWEVER I’m having a problem with my main text container. If I enter a table of paragraph in there the links stop working and text is non selectable (within the table and p and from there on after).

    Does anyone have an idea what I have done wrong? I have been blaming my CMS for a while now but after considerable debugging I can see its definitely my code!!!

    http://www.firstportshipping.com/tester.php

    Any help would be greatly appreciated!!!

    #47605
    Chris Coyier
    Keymaster

    This reply has been reported for inappropriate content.

    It’s the position: relative on your footer that is causing the problem. It’s basically creating a huge transparent box and covering your content. Removing that works, then you’ll have to "push it down" using a different technique, maybe some top padding?

    #47607
    adhoc01
    Participant

    thanks a heap!!!!! Its been driving me mad.

    Just to end the question; it was solved by setting the z-index to -1.

    Really appreciate the help Chris.

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘CSS’ is closed to new topics and replies.