The Lodge is members-only design/dev videos and Office Hours.

Next Office Hours Session: "Implementing an SVG Icon System" Nov 30 - 6:00 PM Eastern

jQuery plugin on wordpress

  • # February 18, 2010 at 5:12 pm

    Hi everybody!

    I was trying to use the idleTimer plugin on wordpress ( ) , but it keeps telling me that "idleTimer is not a function".

    The JS file is being loaded at the header,right after the jquery file, I can see that. I think it has to be a problem with the jQuery scope, which is kind of weird in WordPress. But I’ve tried every possible solution that I found on the internet, and none worked.

    I’ve tried using var $ = jQuery.noConflict(); and then


    $(document).bind(“idle.idleTimer”, function(){


    $(document).bind(“active.idleTimer”, function(){




    but it doesnt work. Maybe I have to change the plugin file?
    The plugin file defines the function like


    $.idleTimer = function f(newTimeout){
    // Stuff

    }; // end of $.idleTimer()


    Any ideas? Thank you.

    # May 26, 2014 at 10:59 pm

    hi did you get any solution

    # May 27, 2014 at 12:30 am

    You’re calling the function before it’s defined. Make sure the plugin is loaded first before calling it.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

There's a whole bunch of content on CSS-Tricks.

Search for Stuff   •   Browse the Archives

Get the Newsletter ... or get the RSS feed