Give help. Get help.

  • # October 15, 2012 at 9:51 am

    Basically my nivo slider doesn’t seem to load all the time on a website I am working on, however the exact same code and website works fine on an earlier version and I am stuck to where I have gone wrong.

    []( “GK”) – this is the site which isn’t loading the slider correctly all the time.

    []( “Kyle”) – this is the site that loads the slider perfectly fine every time.

    Any help is greatly appreciated.



    # October 15, 2012 at 4:40 pm


    # October 16, 2012 at 10:30 am

    Still struggling with this if anyone can help?

    I have looked into having multiple jQuery versions running, but can’t seem to find the problem.

    # October 16, 2012 at 10:38 am

    I think that could be the problem. I see you have



    try removing the older one..

    # October 16, 2012 at 10:38 am

    also try removing the datePicker plugin because I see it’s throwing an error in the console

    # October 16, 2012 at 10:44 am

    Also it looks like you have nivo’s script imported correctly in the old version but not in the new one. Searching for “nivo” in your source code only shows html and css codes.
    Is it a static page? Or how do you load the script?

    # October 21, 2012 at 1:24 pm

    Thanks for your help, removed one of the jQuery codes, and have tried to fix the file structure… still no luck.

    I am unsure about the datePicker plug-in as it shouldn’t even be there?

    # October 30, 2012 at 9:40 am

    Still haven’t been able to work it out, but really need to fix it!

    Can anyone help me further?


    # October 30, 2012 at 11:26 am

    I still see this error in the console:

    Uncaught TypeError: Object [object Object] has no method ‘datepicker’

    I think this might be the problem. The error stops javascript and the slider doesn’t load.. I don’t know where this comes from

    # November 1, 2012 at 8:11 am

    I tried looking for the cause of that, and am completely lost.

    Thanks for helping me narrow it down to this, I’ll work on it again tonight to try and find a solution!

    Do you have any guesses at where the datePicker plug in is loading from?



    # November 3, 2012 at 6:38 am

    I think I have sorted it!

    There appears to be a problem associated with the datePicker plug-in from the contact form plug-in, and the nivo-slider I am using on the homepage. This seems to be causing trouble for a few people…

    Visit here to read other people’s ideas:

    Personally I just removed the wp header, and wp footer – as neither of them were in use on my index page.

    Thanks for your help JoniGuiro, narrowed it down for me!


    # November 3, 2012 at 10:01 am

    Forget what I just said.

    Still having problems, if any can help!

    # December 1, 2012 at 5:04 pm

    Turns out there was actually a problem between Nivo Slider and the Contacts forms.

    I just used a different slider plug-in available through WordPress.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.