The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums Design iOS Safari Caching problems: How to get iOS Safari to behave a bit better.

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #274944
    Joseph Levin

    I hope the following can be helpful to those of you that have had or are having issues with iOS Safari not letting go of some cached files (Since approximately iOS 10.4+).

    Here’s the situation:
    You’re working on a web page on desktop computer, then you take a look at the mobile version of it within iOS Safari. Everything looks great, but then you find that there are a few tweaks that need to get made. You change the CSS locally, re-upload it to the remote server, then reload the page in Safari. Nothing has apparently updated or changed, so you tap reload again, because it sometimes would take 1 to 2 tries before Safari loaded the changed asset. This too doesn’t work.

    Solution? Switch over to Settings->Safari and manually clear Safari’s cache. Then (if you’re me) you open Mail, and click on the link to the remote website so Safari reloads the entire thing.

    This gets very old, very fast and really was a pain to deal with.

    I tried using some of the typical cache-busting techniques, like appending random numbers onto the URL of the most-changing assets (CSS/JS files, etc.). I adjusted the META tags. Nothing worked consistently. Much of the Google supplied answers did nothing. I chatted with 3-levels of escalated Apple tech support. They were professional. They were nice. They stuck with me until they understood the problem. Ultimately, though they tried, they were not helpful and eventually asked if the various web hosting companies that I worked-with were “compatible with iOS 11.3 or 11.4”.


    Anyway, long story short, I stumbled upon this link:

    The article author had the same issue and explained that if you tapped and held the reload button in iOS Safari a dialog is supposed to come up with options to “Reload Without Content Blockers” as well as “Request Desktop Site”.

    Trying this, I found I did not have the option to “Reload Without Content Blockers”, and wondered why.

    Google came up with this link when I tried to find out how to enable the option:

    I needed a content blocking app on my iDevices. I followed the instructions and found, to my surprise, that I had installed “Firefox Focus” (but had forgotten about it.)

    After enabling Firefox Focus as a “Content Blocker” in Settings, I was able to get the “Reload Without Content Blockers” option to appear in Safari, and it worked.

    Tapping on that option is SO much quicker and easier to deal with than manually clearing the cache, so I thought I’d share the info here.

    I sincerely hope it helps.


    Hey, great tip! Thank you for your post!

Viewing 2 posts - 1 through 2 (of 2 total)
  • The forum ‘Design’ is closed to new topics and replies.