Forums

The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums Back End Including my header on phpBB

  • This topic is empty.
Viewing 1 post (of 1 total)
  • Author
    Posts
  • #35473
    Diojr
    Member

    Hey guys.

    Ok, so i’m not really sure whether or not i’m out of line for posting this, but if i am i apologize in advance.

    I am currently developing af danish news site about Android (located at http://www.ndroid.dk), and for that site i wanted to include a forum. I am not happy with the current available WordPress forum’s, and since our site is non-profit, i went to gold old phpBB – as i have a lot of time before.

    My phpBB installation is located at http://www.ndroid.dk/forum/

    What i really wanted to do, was integrate our phpBB forum somewhat into the site, and it was searching the web about that, that i stumbled upon this site and your video tutorial on how to do just that (video #48). I have pretty good understanding of how HTML and CSS works, but i would call myself an extreme novice when it comes to PHP.

    I of course ran into several problems with the integration on my header, and i think its mainly due to the fact that our current WordPress theme, is quite advanced and calls a lot of PHP in the header – which somehow doesn’t get called when they are suddenly called from the /forum/ directory (i might be 100% off though).

    My header.php looks like this, and i tried copying everything from after the “body” tag, as you explained in the tut, to my overall_header file



    >




    <?php wp_title('', true, 'left'); ?>

















    wp_localize_script('AvenueTheme', 'AvenueVars', array(
    'ajaxUrl' => admin_url('admin-ajax.php'),
    ));
    ?>









    >






    'topNav', 'depth' => 3, 'fallback_cb' => false, 'menu_class' => 'topNav')); ?>









    I also added the tag to the overall_footer file. I also added the relative link to my style.css file to my overall_header.

    The result was a 100% mess, where the phpBB itself lost all styling, and none of my own header appeared. After the page got cached, it showed only a blank page, and i had to delete the cache files to show the mess once more, before it showed blank page again when the new cache was made.

    I apologize for bad english, as this isn’t my native tongue.

    – Rasmus

Viewing 1 post (of 1 total)
  • The forum ‘Back End’ is closed to new topics and replies.