Forums

The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums CSS Firefox, ie, safari, opera…. haarrrr. :o

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #27522
    CKLFP
    Member

    Hi, my name is Luis Filip Pa├žo and I recently open a litle biz, I’am bulding the web page, my own, but things are not going so well.
    Here is the link http://www.pcko.biz/testes/.
    The problem is as follows.
    In firefox every thing is more or less ok, is not perfect but with time I get there, BUT in ie, Ho God what a mess, link won’t link, shadows won’t shadow (text and box) every thing is out of control. :evil:
    Chris or some one, what do you need to help me to replicate in IE what I have in FF :?:
    Do I need to do the same for safari opera and so one :?:

    Hope you can help. Thanks in advanced.

    #69206
    AshtonSanders
    Participant

    Well, to start, I would validate your code: http://validator.w3.org/check?verbose=1 … Ftestes%2F
    That is probably why your links won’t link.

    IE doesn’t do CSS shadows. IE6 has a problem with clear PNGs. You’ll need a PNG hackto fix it.

    Start with that.

    #69223
    CKLFP
    Member

    Hi, AshtonSanders.

    Thanks for you help. In fact there were errors, but some of them I couldn’t track, but most of them are eliminated, thanks.
    But my problem is still there. after a few hours and some burning eyes :lol: , I tracked the click problem, but I don’t now how to solve it.

    All the pages are being feed by PHP and in the beginning of the body I’m calling a bg.html page with this code:

    Code:

    The CSS applied is this:

    Code:
    .bg { position: absolute; top: 0; right: 0; bottom: 0; left: 0; }
    #bg1 { background: url(“../imgs/bg/bg1.png”) repeat 90% 60%; }
    #bg2 { background: url(“../imgs/bg/bg2.png”) repeat 110% 85%; }

    If I disable the ,bg class, I regain the click ability, but I lost the bg Efect (resize browser and you will see that the 2 images move in two different speeds.).
    What shell I do to be able to kept the two things.

    Thanks again.

    #69268
    AshtonSanders
    Participant

    Hmmm… It sounds like those background Divs are being place on top of the rest of your content… so when you click, you click on the div, instead of the link.

    Try adding "z-index:-100" to the .bg class.

    #69275
    CKLFP
    Member

    Hi, AshtonSanders.
    I supose it could work, but I found this http://conditional-css.com/index take a look.
    Right now I think is a good solution it’s easy to use and is solving all my problems (that one include).
    Thanks again. :D

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘CSS’ is closed to new topics and replies.