The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums Other error with nav links after database transferred

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #43795

    Following my previous discussion, I’ve managed to transfer the database from localhost to url/wordpress.

    Everything is there, content, panels, etc… but when I go to the live server:
    -The home shows all right, with slideshow and all.
    -When I click on any of the links of the main nag to go to the other pages it just displays the following error:

    Not Found

    The requested URL /wordpress/services/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I’ve used the Velvet Blues Update URLs and all the permalinks are looking good.
    I’ve manually changed the url’s in the cpanel just in case that was the problem.
    I’ve reloaded the menu with the pages to see if I could make it work.

    But nothing has worked.
    Can anyone help please?

    Thanks, Eu


    It kinda has to be the permalinks setting in your WordPress admin though.

    Not sure which method you used to transfer your database. If you did an export (on local) and then import (on server) both through PHPmyadmin, it should have gone right. However if you did it within the WordPress admin, it’s very likely you only transferred the CONTENT and not a bunch of SETTINGS (including the permalinks setting).

    You could try uploading your local .htaccess file to your server, that helps sometimes. Or check if the URLs (WordPress URL and Site URL) are correct — you may have to get rid of the “/wordpress” part in one of them or both.


    Hi, I’ve used the Phpmyadmin method. Everything shows in there. Even the permalinks at the top are correct.
    The /wordpress is because it’s still not published officially. So I created a subfolder to store the site so we can upload the final data before going live. Meaning I’ll have to do this again shortly :)
    I’ve tried the .htaccess file thing but that didn’t work.

    Thanks for your help.


    Wordpress URL and Site URL (in Settings – General) both also have the /wordpress part in it?


    Just replaced the .htaccess file text for the one shown in the permalinks tab and that seemed to do the trick. So all good now.

    Thanks for your help Senff.

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Other’ is closed to new topics and replies.