Forums

The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums CSS css animation timings out of whack in Firefox

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #266312
    MBM
    Participant

    I’m running code that was written about 4 years ago. I know -moz- is no longer necessary but I tried to remove it and it didn’t help.

    I have four icons sliding from left to right, once after another. In chrome and IE, the animations play fine. In firefox the timings are out of whack. Am I missing a change in code or should I give up on this and use a jquery script instead?

    The pen is here:

    https://codepen.io/MBM/pen/seIiE

    #266333
    JeroenR
    Participant

    Yes that looks weird in Firefox. Seems the rerendering only is correct when your mouse is active in the screen.
    Maybe try something else like this: https://codepen.io/anon/pen/wyzbwe
    The animated blocks must be in the viewport, or at least almost in the viewport. Can’t explain it though.

    #266335
    Shikkediel
    Participant

    The strangest thing is that is only occurs with absolute positioning…

    It’s like the third time I’ve recently come across something similar by the way. Without ever finding any clue about it on Google.

    https://css-tricks.com/forums/topic/animation-plays-weirdly-in-rotated-container/

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘CSS’ is closed to new topics and replies.