Forums

The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums CSS 3d transform not working google chrome

  • This topic is empty.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #41799
    sanketjazz
    Member

    hi,
    i just want to know that why 3d transform is not working on google chrome, same code working in firefox properly.
    plz help.

    source code





    Untitled Document




    #120060
    chrisburton
    Participant

    Try using the webkit prefix. `-webkit-transform`.

    #120175
    GMB
    Participant

    Funny the 3D transform stopped working on [my site](http://www.guybennett.com) with Chrome as well (still works in FF and Safari), and I am using the webkit prefix (with “transition” not “transform” — could that be the issue?).

    #120177
    chrisburton
    Participant

    @GMB Yep. You need the -webkit- prefix. http://caniuse.com/#search=transform

    Your site transform works for me. Pretty cool, by the way.

    #120178
    GMB
    Participant

    I am using the webkit prefix and the 3D transform used to work with Chrome. At one point that changed (though the code hadn’t). I don’t know why.

    #120204
    GMB
    Participant

    @chrisburton — I’d love to take credit for the effect, but it’s a very lightly retinkered version of Hakim El Hattab’s Meny.

    I’m puzzled though — the 3D transform is *not* working for me with Chrome. Don’t understand why.

    #120205
    chrisburton
    Participant

    @GMB Hey, sorry. It’s probably best if you create a reduced test case on CodePen. This way we can eliminate the issue.

    #120208
    GMB
    Participant

    Just noticed that Hakim’s [Meny demo](http://lab.hakim.se/meny/) is not 3D transforming either in Chrome.

    Hmm…

    #120210
    chrisburton
    Participant

    @GMB It’s definitely on your end because it works for me: http://cloud.chrisburton.me/M0GQ

    #120221
    GMB
    Participant

    @chrisburton — I’ve been trying to think of what it could be but have come up blank. I’ve check my settings — they look normal. JS is definitely enabled.

    Any idea what might cause this? If not perhaps I’ll reinstall Chrome and see if that works.

    #120223
    chrisburton
    Participant

    @GMB It might be the settings which you could have overlooked. No idea, to be honest.

    Type this into Chrome and check: `about:flags`

    #120532
    GMB
    Participant

    @chrisburton — Thanks for pointing me to about:flags, which I was unaware of. Even with that however I was unable to figure out what was wrong and so wound up reinstalling Chrome — the 3D transforms work as they should now. I appreciate your help.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.