The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums CSS Z-Index on IE8 with <object> tag Re: Z-Index on IE8 with tag


Thanks TheDoc,

after trying around with z-index and guessing it could have to do with the object being placed in a table (which turned out not to be the problem) I found this: … ?cid=E5141

It seems, that what is described above for the <object> Tag and Flash seems to cause the problem for my ActiveX object. However, I couldn’t transfer the solution that was available for Flash objects to my ActiveX object.

Here is, what they propose for Flash objects (using Dreamweaver, but you can also do it directly in the code):

If you have already published you can make a change to your HTML code using either Dreamweaver’s Property inspector or by editing manually. To use Dreamweaver:

1. Select the Flash movie in your document in design view.
2. Choose Parameters in the Properties inspector.
3. In the Parameter column, enter wmode. In the Value column, enter either transparent or opaque.
4. Save your document.

If you prefer to edit your HTML by hand, there are two areas you need to tweak:

1. To the Object tag, add the following parameter (opaque is shown as an example):
<param name="wmode" value="opaque">

2. To the Embed tag, add the following attribute:

There is no Embed tag for ActiveX, so I can not make it opaque. Searching the web didn’t return a useful result. Also I tried to put the whole ActiveX object onto another html-page and included that through an z-indexed i-frame into the front page. No luck at all.