The forums ran from 2008-2020 and are now closed and viewable here as an archive.

Home Forums Other Long “Wait Time” in WordPress Re: Long “Wait Time” in WordPress


Both sites load slow for me as well, but the latter is especially worse.

For the first site, based on the source code, it doesn’t look like you’re actually using caching–There’s no cache comment at the end of your source code.

As for the second site, I see you’re using W3 Total Cache, but it’s not actually caching. You can see this for yourself by loading the page and looking at the source code timestamp at the bottom. Then reload the page, look again, and you’ll find the timestamp update. That means WordPress is generating your pages from scratch every time. Unless you know you need it, you may want to turn off object caching. Just using the disk enhanced/basic page caching should be sufficient for most sites. Make sure W3TC is able to write to your .htaccess file as “disk enhanced” caching uses .htaccess mod_rewrite rules, while the simpler “disk basic” caching does not use rewrite. Try switching to basic caching to see if that makes a difference. You’ll have to check the source code timestamp to see if it’s working properly.

You may want to post this on the W3 Total Cache support forum. The recent update of a few days ago (v0.9.2.5) seems to have given some folks some difficulty with their caching. Some have reported their site slowing down since then. You also may want to try WP Super Cache as an alternative:

With all that said, without knowing what other plugins you have installed, it’s hard to say what the issue is. It may another plugin causing this.