Grow your CSS skills. Land your dream job.

Wrong colors in Firefox 3.5

  • # July 28, 2009 at 6:56 pm

    Normally I use Firefox as my favourite browser, but in the latest version 3.5 (or precise: 3.5.1) color correction is turned on by default. In some cases this is nice i.e. when viewing photographs, BUT in webdesign this is a disaster! I.e. many PNG’s are not rendered "correctly" or in the way they are suppose to. Often they appear darker than expected by the designer. Say you have a PNG image with a color which is meant to be the same as the body’s background color but when it is rendered the colors don’t look identical.

    I have googled the problem and found several other forums which discuss this issue, but I thought it would be interesting to get the opinion from some CSS-tricks-guys.

    Mozilla have described the feature themselves:
    https://developer.mozilla.org/En/ICC_co … in_Firefox

    Some technical explanation:
    http://hacks.mozilla.org/2009/06/color-correction/

    Others opinion:
    http://stackoverflow.com/questions/1108 … ction-hack

    # July 29, 2009 at 1:57 am

    this is an enhanced engine that is turned on automatically.

    I turned something called gfx.color.management.mode from 2 to 0

    that should fix your problem

    # July 29, 2009 at 7:53 am
    "ikthius" wrote:
    this is an enhanced engine that is turned on automatically.

    I turned something called gfx.color.management.mode from 2 to 0

    that should fix your problem

    Yeah I know. I’ve done that too. But even though it now looks normal in MY OWN browser it will still look odd to the user of the site who is not a tech freak.

    # July 29, 2009 at 12:20 pm
    "Hoejlund" wrote:
    "ikthius" wrote:
    this is an enhanced engine that is turned on automatically.

    I turned something called gfx.color.management.mode from 2 to 0

    that should fix your problem

    Yeah I know. I’ve done that too. But even though it now looks normal in MY OWN browser it will still look odd to the user of the site who is not a tech freak.

    that is correct but Mozilla know this is not working out the way they wanted, so in future releases (never far away) they are setting this off by default, and making the engine better.

    # July 29, 2009 at 4:51 pm
    "ikthius" wrote:
    "Hoejlund" wrote:
    "ikthius" wrote:
    this is an enhanced engine that is turned on automatically.

    I turned something called gfx.color.management.mode from 2 to 0

    that should fix your problem

    Yeah I know. I’ve done that too. But even though it now looks normal in MY OWN browser it will still look odd to the user of the site who is not a tech freak.

    that is correct but Mozilla know this is not working out the way they wanted, so in future releases (never far away) they are setting this off by default, and making the engine better.

    I hope so

    # July 29, 2009 at 5:31 pm

    if you want the site lo look uniform on all browsers, don’t use PNGs

    # July 30, 2009 at 10:06 am

    I’ll try

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".