Grow your CSS skills. Land your dream job.

Works fine on computer, not uploaded

  • # May 11, 2010 at 5:32 pm

    Hi! I’m just learning CSS & am working on a site.

    I’m a bit confused because I have two elements where I need a background color.

    It works fine when I open the html file in IE8 from the files my local machine, but when I upload the files to the site, all of the the css works except the background color tags. (all the css tags are in an external css file, which is uploaded & I’m assuming it’s correctly linked to or the other css tags wouldn’t work, right?) (And, yes, I’m using the same computer, same browser to view in both instances.) Any ideas?

    # May 11, 2010 at 7:11 pm

    Can you post a link to your page?

    # May 11, 2010 at 9:56 pm

    The site where I’m testing the css is http://www.goldpanfunding.com/test/index.html

    There’s supposed to be a greenish bar across the page at the "welcome" and the table in the footer should have the same color background.

    Of course, I’ve since noticed that the footer css doesn’t work on other browsers…

    # May 12, 2010 at 10:22 am

    Looks to me like you forgot to upload your CSS file.

    View the source on your online demo.

    Code:

    When you try to open gpfCSS4.css in your browser, you get 404′d.

    # May 12, 2010 at 4:29 pm

    Ah, found the problem. The file was uploaded but had different capitalization in file name & the link.

    So why did the sticky footer work but not the background?

    Thanks for the help!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".