Grow your CSS skills. Land your dream job.

WordPress – Permalinks not working – WAMP

  • # February 17, 2011 at 2:52 am

    Hi guys

    Chris mentions at the beggining to change the permalinks setting to be more seo friendly but everytime I do I get this message.

    “Not Found

    The requested URL /2011/02/17/hello-world/ was not found on this server. “

    This is the address Im getting the error from:
    http://localhost/2011/02/17/hello-world/

    I also get the error when trying to do it this way (not at the same time)
    http://localhost/wordpress/2011/02/17/hello-world/

    Any ideas why this is going wrong…? I must add I get an error like this for every link.

    # February 17, 2011 at 3:46 am

    when working on localhost, you need to set the php settings differently. If you are running wamp, you nee to click on the wamp server, choose the apache menu -> apache modules then move the menu down and choose rewrite_module. You will need the server to restart for the changes to take affect. It might restart on it’s own but if it doesn’t, restart it manually. that should do the trick

    # February 17, 2011 at 4:10 am

    Yep that fixed the little blighter.

    Thanks cyber :-)

    # February 17, 2011 at 4:15 am

    your welcome

    # April 5, 2011 at 6:13 pm

    Cybershot you are a star. That fixed my problem.

    # March 8, 2012 at 10:46 pm

    OMFG! Thank you, thank you, thank you. Been struggling with this for two nights. Thinking I was going nuts, nope, just needed to find the right forum.

    # June 27, 2012 at 9:37 am

    I’ve adjusted the Apache settings to rewrite_module, but it just redirects my posts to the default WAMP home page. please help.
    Will

    # November 25, 2012 at 6:11 am

    Thanks Cybershot! Spent an hour searching for something so simple!

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘WordPress – Permalinks not working – WAMP’ is closed to new replies.

*May or may not contain any actual "CSS" or "Tricks".