Grow your CSS skills. Land your dream job.

Webpage looks good in IE but not in FF3

  • # November 27, 2008 at 12:10 am

    Hi I’m new to this forum also new to CSS.

    I really need some help with my CSS , I’ve created it and I don’t really seem to understand why
    IE shows the webpage as i designed it and FF3 doesn’t show how I created it at all.

    I’ve uploaded the webpage to test it ,if you open it with IE it is like I designed it, when
    opening with FF3 It doesn’t look good at all.

    If you want to take a look this is the link to the page
    http://www.southbridgeict.com/testaward … /index.htm

    I have added my style sheet , If someone please can help me to correct it so it will work properly in FF3, please do.

    Donovan

    # November 27, 2008 at 12:22 am

    Just had a quick look, first thing, you shouldn’t use "&nbsp;" and "<br /" as tools to help in design. That should all be done in the CSS.

    It looks relatively normal for me in Safari and FF3 (both on Mac). What specifically isn’t right?

    # November 27, 2008 at 10:27 am

    ok that’s clear than. But in IE the page looks like this http://www.southbridgeict.com/testawards/IE.jpg thats the correct lay out to me. The image should be under the menu bar. But FF3 doesn’t show this bar at all.
    In FF3 it looks like this http://www.southbridgeict.com/testawards/FF3.jpg, if I remove the %nspb & BR , it doesn’t help at all. Still don’t seem to get what i’m doing wrong.

    # November 27, 2008 at 1:25 pm
    Code:
    #menu li a:hover { background-color: #333; color: #9c0; height: 20px; }
    }

    Remove the extra closing bracket.

    Then create this:

    Code:
    #menu {
    width:800px;
    height:25px;
    }

    There are numerous things going on wrong within both the CSS and HTML, but they were far too many for me to be able to squeeze in during work. Good luck.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".