Grow your CSS skills. Land your dream job.

Troubleshooting for a warning:[Web App from scratch series]

  • # April 26, 2013 at 11:05 am

    Hi,
    I am trying to follow [the Creating a Web App from Scratch series](http://css-tricks.com/examples/WebAppFromScratch/ “the creating a Web App from scratch series”) ,I have no prior experience with PHP,I’v downloaded the source file and uploaded to a host just to see if it works for myself([Your text to link here...](http://listitbright.nazuka.net/site/ “site”))

    but the screen shows me this error:

    Warning: require_once(inc/FirePHPCore/FirePHP.class.php): failed to open stream: No such file or directory in /home/u265831516/public_html/site/common/base.php on line 13 Fatal error: require_once(): Failed opening required ‘inc/FirePHPCore/FirePHP.class.php’ (include_path=’.:/usr/lib/php’) in /home/u265831516/public_html/site/common/base.php on line 13

    Could anyone guide me through the right way?Did I upload the content in the wrong directory? Thanks in advance.

    # April 26, 2013 at 5:00 pm

    @Nick01 I think you might have put the file in the wrong directory…Could you please check and tell us if you did?

    # April 26, 2013 at 5:27 pm

    I’v uploaded the files in public_html(since all the content here is visible to public) and then I wanted a subdirectory called “site” so, public_html/site/ (here the downloaded file).
    here’s my filezilla screenshot:

    http://oi44.tinypic.com/f0cew6.jpg

    __
    # April 26, 2013 at 7:49 pm

    It’s looking for a file named `FirePHP.class.php` in your `/home/u265831516/public_html` `/site/inc/FirePHPCore/` directory. Does that file exist on your server?

    # April 26, 2013 at 8:37 pm

    You sure @traq? The script causing the error is `/home/u265831516/public_html/site/common/base.php`, so it’s looking for `/home/u265831516/public_html/site/common/inc/FirePHPCore/FirePHP.class.php` unless I’m mistaken. Try:

    require_once(../inc/FirePHPCore/FirePHP.class.php)

    # April 27, 2013 at 3:49 am

    @traq The file FirePHP.class.php hasn’t been provided in the source code download file and isn’t present in /home/u265831516/public_html /site/inc/FirePHPCore/ Am I supposed to create one?

    @CrocoDillon The line exists in base.php. This is the code of [base.php](http://oi44.tinypic.com/33yt2sh.jpg “base.php”)

    # April 27, 2013 at 6:04 am

    I guess you could get a copy from https://github.com/firephp/firephp-core/tree/master/lib/FirePHPCore

    Seeing including the constants doesn’t give a warning I guess my earlier statement was wrong.

    # April 27, 2013 at 6:58 am

    @traq ,@CrocoDillion The link worked like magic!

    But There’s a new warning:

    Connection failed: SQLSTATE[28000] [1045] Access denied for user ‘db_user’@’localhost’ (using password: YES)

    I’m Guessing this is because no permission is granted to the database?
    The series aimed at creating a db in XAMPP,so I am not sure the same steps are supposed to be followed on a web host?

    __
    # April 27, 2013 at 1:29 pm

    How you connect to your DB will depend on how your DB is set up. You should be able to get host/user/pass/etc. from your host.

    # April 28, 2013 at 5:18 am

    What caused that warning? my host doesn’t provide a MySQL database wizards* where permissions can be given to the database users I suppose? [Cpanel](http://i43.tinypic.com/2mw9zpj.jpg “host”)

    # April 28, 2013 at 6:25 am

    What do you have when you go to MySQL Databases?

    # April 28, 2013 at 8:03 am

    [MySQL Databases](http://i41.tinypic.com/34fidjd.jpg “MySQL Databases”)

    Tried to import the database and tables :

    [Error while importing from database created in XAMPP](http://tinypic.com/view.php?pic=30lj8eb&s=5 “Error while importing from database created in XAMPP”)

    I’v tried :
    GRANT ALL PRIVILEGES ON *.* TO ‘myuser’@’%’ WITH GRANT OPTION;

    Still it keeps giving me the Connection failed error.

    # April 28, 2013 at 8:24 am

    Probably best to wait for @traq‘s reply… but I’d say you’re trying to connect to localhost, try mysql.nazuka.net instead, in your DB connection script.

    # April 28, 2013 at 8:52 am

    If you meant instead of ‘localhost’ I should use ‘mysql.nazuka.net’, it still gives the same error:

    Access denied for user ‘u265831516_nick’@’localhost’ to database ‘u265831516_first’

    # April 28, 2013 at 10:35 am

    Does your webhost allow you to create new databases? Have you tried just using the database you do have?

Viewing 15 posts - 1 through 15 (of 24 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".