Grow your CSS skills. Land your dream job.

Slides not sliding, just stacking.

  • # January 26, 2012 at 12:31 pm

    I have used Anything Slider on other websites and it worked fine. However I am adding it to an existing site I did not build. There are a bunch of plugins already installed. The slides are just stacking on the page instead of sliding. I tried deactivating all plugins and I also tried this: http://stackoverflow.com/questions/3800039/need-help-resolving-a-javascript-conflict-using-jquery-anything-slider
    and this: http://wordpress.org/support/topic/plugin-anythingslider-for-wordpress-nothing-but-trouble-so-far
    But they still stack. The site is: http://playgolfarizona.com/.
    Any help would be greatly appreciated. Thank you.

    # January 26, 2012 at 10:44 pm

    You loaded more than one JQuery:



    Use only the most recent one.

    # January 27, 2012 at 11:24 am

    Thank you for your response. However, I took out one, then the other, then both. It still is stacking the slides. Any other ideas? Sorry I really don’t know much about JQuery.

    # January 27, 2012 at 11:36 am

    I think because you also have Scriptaculous, you’ll need to add the following immediately after jQuery is loaded:

    # January 27, 2012 at 12:08 pm

    I added it right after the first script but Dreamweaver showed a PHP Scripting error if I so I added it like below and now I have the 2 of each slides loading on top of each other. I am not sure what scriptaculous even does so should I just remove it?




    # January 27, 2012 at 12:09 pm



    # January 27, 2012 at 12:27 pm

    I can’t tell what it does either, but since we added the noConflict, this code needs to change… change the “$” into “jQuery” to fix that one error.

    $(document).ready(function() {
    $('#featured .scroll').quovolver(1, 10000);
    });

    change to:

    jQuery(document).ready(function() {
    jQuery('#featured .scroll').quovolver(1, 10000);
    });

    So now it looks like AnythingSlider should be running, but it could just be the above error preventing further down code from running, so we’ll just need to see if the above change fixes everything or what the next step needs to be.

    # January 27, 2012 at 12:46 pm

    Slides are back to stacking. I turned off all plugins and uninstalled/reinstalled Anything Slider and same thing. Below is the Javascript





    # January 27, 2012 at 2:25 pm

    The noConflict code still needs to be the next line after the jquery script. As it is now, the quovolver script won’t exist when it’s run because it is loaded before the noConflict.

    # January 27, 2012 at 3:12 pm

    I was able to eliminate the PHP Syntax error by dropping the closing script tag. Slider is still stacking. I really appreciate all your help.




    # January 27, 2012 at 3:18 pm

    That closing script tag needs to be there, now I’m getting another error: “Uncaught SyntaxError: Unexpected token <“

    # January 27, 2012 at 4:49 pm

    Since this is just a test site. If you know what script is conflicting. I will just strip it out. I am just trying to update the site until the client has me do a complete rebuild. Thank you.

    # January 27, 2012 at 5:07 pm

    Ok I got it working… I commented out this line… I’m not sure what this plugin does, but it’s causing an error.

    //jQuery('#featured .scroll').quovolver(1, 10000);

    Then I noticed that the AnythingSlider.css file was missing, so I added it and then I had to set the slider dimensions to 600×400 because it’s set to 570×190 for some reason

    #slider-210 { width: 600px; height: 400px; }

    The default stylesheet I used really messed up the slider because of the external arrows – it was shifted to the right, but it was working. So, I’m just guessing you already have an AnythingSlider theme ready, it just that the link to it isn’t there.

    # January 27, 2012 at 5:59 pm

    Still not working for me. Here is the code. I probably missed something. Slides are duplicated and stacking.





    # January 27, 2012 at 6:11 pm

    ok. I forgot that I uninstalled and reinstalled anything slider. so all the settings were back to default. I set them to what I wanted and the slides are now rotating, but well below the window. probably need to work on css style now. thanks for all your help. have a great weekend.

Viewing 15 posts - 1 through 15 (of 30 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".