Grow your CSS skills. Land your dream job.

#respond & #comments disapear all content

  • # January 2, 2009 at 9:58 am

    Hi, I have a big problem, everything work ok, but when clicking the comments icon to respond or see comments, the page loads and then the main content disapear.

    Being in homepage and clicking comments you got a #respond or #comments after the address depending if the entry has or not comments. It loads and then it disappears, the sidebar stays there.

    I remove the #respond or #comments from the address and it loads ok.

    Its the default theme in wordpress 2.7, any ideas ?

    Maybe the style stuff in header I do not use ?

    Code:

    < ?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>

    < ?php wp_head(); ?>

    I just added an e to the images directory name, so nothing loads there.

    You can see it here, clicking in the comments icon.

    Thanks in advance.

    # January 5, 2009 at 11:28 am

    No one ? I am still stuck with this :cry:

    Thanks.

    Rob
    # January 5, 2009 at 12:28 pm

    <div class="narrowcolumn" id="content" style="display: none;">

    For some reason you have that line (in bold) in your narrowcolumn div html – when the site loads fully, it will load that peice of CSS last, making everything in that div vanish. Remove it an it works fine :)

    # January 5, 2009 at 1:34 pm
    "Robskiwarrior" wrote:
    <div class="narrowcolumn" id="content" style="display: none;">

    For some reason you have that line (in bold) in your narrowcolumn div html – when the site loads fully, it will load that peice of CSS last, making everything in that div vanish. Remove it an it works fine :)

    Thanks Robskiwarrior.

    I can’t find it, can you please point me where did you see it or where it should be, it seems Im blind here. I see firebug shows it, but theres nothing like that in my style sheet. Or at least I cant find it.

    Thanks.

    Rob
    # January 5, 2009 at 2:04 pm

    Thats strange… cant see it either…

    The only thing I can think is happening is that some JS somewhere is adding the style to that tag for some reason.

    What I mean is sometimes with a lightbox effect or other types of JS effects you can select and style objects.

    Maybe something is picking up on an atribute of that div, its id or class, and is deciding to give it the display:none; so that it is ready to be revealed by some script…

    Thats the only thing I can think of, you do have alot of script linked in there. Does that make sense?

    # January 5, 2009 at 4:12 pm
    "Robskiwarrior" wrote:
    Thats strange… cant see it either…

    The only thing I can think is happening is that some JS somewhere is adding the style to that tag for some reason.

    What I mean is sometimes with a lightbox effect or other types of JS effects you can select and style objects.

    Maybe something is picking up on an atribute of that div, its id or class, and is deciding to give it the display:none; so that it is ready to be revealed by some script…

    Thats the only thing I can think of, you do have alot of script linked in there. Does that make sense?

    Thanks Robskiwarrior.

    It seems its the "domtab.js" I use for tabs in the sidebar, no idea why its doing it and no idea how to fix it.

    At least I know where the problem is and will also look into it.

    Any ideas ?

    Thanks.

    Rob
    # January 5, 2009 at 4:37 pm

    any chance you could paste the contence of the JS file in here? :D

    Rob
    # January 5, 2009 at 4:56 pm

    my JS isnt great… but its being added in line 55 and/or 173 – I think its actually something to do with line 55, as contentElements relates to a div according to the top of his document…

    Other than that I have no idea :D but I know that the style is added in line 55 and 173 :)

    # January 5, 2009 at 5:20 pm
    "Robskiwarrior" wrote:
    my JS isnt great… but its being added in line 55 and/or 173 – I think its actually something to do with line 55, as contentElements relates to a div according to the top of his document…

    Other than that I have no idea :D but I know that the style is added in line 55 and 173 :)

    Yes, there are actually just 3 lines with the style none, the problem is changing all three to block or something else, did not solve the problem.

    Dam, this is driving me crazy, I finally finish my design and code launch the site and the tabs are really getting the site down whith that problem.

    Will still be looking into it, if someone else has any clue or another option instead of domtabs, please let me know.

    Thanks.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".