Grow your CSS skills. Land your dream job.

Problems with Markup Validation

  • # September 6, 2008 at 12:05 pm

    Hi,

    i found your page with google and I must say it looks very nice. I watched all your screencasts… wonderful. I am actually also a web designer, but not so good as you.

    So my problem is the following. I have a wordpress setup with my own theme. Today I checked my page with the W3C Markup Validator (http://validator.w3.org/) and fixed some problems. But I have 12 problems and 6 warnings where I don’t know whats wrong.

    All the problems refers to this code for my flickr thumbs:

    Code:

    Hope you can help me. My page is http://www.andre-neuborn.de.

    Thanks!

    bye,
    ANeuby

    pab
    # September 6, 2008 at 12:10 pm

    replace all your & with &

    that should fix some of the issues

    hope it helps

    # September 6, 2008 at 2:33 pm

    Wow thanks. But now i have 5 errors remaining. How can I fix this?

    For example, the first error. I have included the alt entity in the img tag but w3c says no. And then it says there cannot be an img tag. How can I escape that?

    bye,
    ANeuby

    pab
    # September 6, 2008 at 3:31 pm

    try removing the alt"flickr" let me know if that works

    # September 6, 2008 at 5:44 pm

    Okay I changed it but it does not work. Now I have 5 problems and it also says that there must be an alt entity.

    Hmm, sorry now I saw that the flickr thumbs does not coming up. So the thing with replace & with & does also not work!

    # September 6, 2008 at 6:15 pm

    Now it works fine! You only need to put the code into an extra javascript file and add it in the header.

    bye,
    ANeuby

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".