Grow your CSS skills. Land your dream job.

Permalink change – now permanently locked out!

  • # July 12, 2009 at 7:15 pm

    Believe me, Chris, I’ve looked everywhere for help on this matter but have gotten nowhere. Seems I goofed up while trying to follow your Video Screencast #26: Designing for WordPress: Part Two.
    Got as far as the part where you talk about customizing the permalink structure. I copied what you had done: Custom Structure /%postname%/. "Put it at slash postname" is what you said, "and I guess you’ll see what that looks like in a minute". Indeed I did. Now I can’t access my blog. 403 Forbidden You don’t have permission to access / on this server. – is what I get. Maybe I didn’t write the word in the box correctly, I don’t know. In the end, I wiped everything, deleted the database and WordPress, created a new DB and uploaded WP again. But I still get the same message.
    Using my host’s administrative package, Parallels Confixx (only sold in Germany), when trying to create the new database I was able to enter a ‘comment’, but the same database name as the old one was automatically generated. To change that, I need to use PhpMyAdmin, but that’s password protected. I’ve written to them requesting access. Is there no other way? Can you please help me? What information do I need to add to this post so that someone can help me? – Desperate

    # July 12, 2009 at 7:34 pm

    If you deleted the entire database AND WordPress and reinstalled everything fresh with a fresh DB, I can’t imagine what the problem could possibly be. That’s a pretty comprehensive wiping. If it happened when you were changing permalinks, that works by changing the .htaccess file at the root of the WP install. Sometimes this file is invisible, so remember to use a program that can see these, and try and delete that.

    # July 13, 2009 at 5:19 am

    Thanks for the quick reply, Chris. I managed to make .htaccess visible and this is what it looks like:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    I can’t access my site at all. Did you say I could delete this file?

    # July 13, 2009 at 9:04 am

    Resolved! I’m up and running again. I did what I understood you to say, deleted .htaccess, now I can see my stuff. I’m going to leave the Permalink Settings at Default for now.
    Thanks for the tip, looking forward to continuing with your Video Screencasts.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".