Grow your CSS skills. Land your dream job.

Parralax scrolling website in IE

  • # May 1, 2013 at 2:45 am

    I’m in need of assistance! I have created a parralax scrolling website for my client, and everything works fine in all browsers, except in IE there is a lot of extra space, and I have tried everything I can think of!

    The testing site is:
    http://www.octaneprotein.com.au/home.html

    Try checking it out in Firefox, then IE. it’s driving me nuts!

    I’m using one CSS for all browsers, and the html5shiv.js.

    # May 1, 2013 at 2:46 am

    Not to mention I’m completely self-taught when it comes to web design X_X

    # May 1, 2013 at 3:03 am

    More or less seems to work OK in IE6, IE7 and IE10. You could use conditional comments to target IE8 and IE9 with some extra CSS to fix them. Not very elegant but would get the job done.

    Another route would be to make a minimal test case to CodePen that replicates the problem.

    # May 2, 2013 at 12:03 am

    You didn’t see the difference between firefox and IE? :
    The site works, but it has cosmetic issues in IE.

    # May 2, 2013 at 12:49 am

    Okay, so IE isn’t reading the correct style sheet. I made two, and the if statements work fine, and it’s recognising different browsers.

    but IE isn’t reading that CSS. it’s still reading the other one. X_X

    # May 2, 2013 at 12:58 am

    You have the IE specific stylesheet loading before the normal stylesheet, Styles cascade, so it will always read the normal one last. Just place it below the normal styles. IE will read both, you want the IE one last.

    # May 2, 2013 at 1:09 am

    Do I need to take away the if !IE comment?

    # May 2, 2013 at 1:10 am

    Also, i’m using html5shiv.js to enable html5 in iE. but this also seems to override the css?

    # May 2, 2013 at 1:14 am

    html5shiv is specific for internet explorers less than 9, so 6, 7, 8 only. You want to use a specific IE conditional for that. http://code.google.com/p/html5shiv/

    Check the path to your IE style CSS, it is currently < ?php echo get_stylesheet_directory_uri(); ?>/stylev2.css the php echo crap doesn’t need to be there, that snippet probably came from something wordpress related and is actually PHP.

    # May 2, 2013 at 1:39 am

    Okay, I’m about to have a heart attack, I’m so confused. And I apologize in advance for being so stupid.
    Did as you said. but it’s still only reading the non-IE css.

    HTML5 shiv seems to be working fine.

    # May 2, 2013 at 2:56 am

    Nevermind! i got it working. It was something reaaaaally stupid that I overlooked. A tiny piece of html in the wrong spot.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".