Grow your CSS skills. Land your dream job.

mysql help, #1045 – access denied

  • # November 27, 2012 at 3:35 pm

    Hello,

    I’m trying to access phpmyadmin locally for my WordPress site (using xampp), and am getting this error: “#1045 – Access denied for user ‘root’@’localhost’ (using password: NO) “

    I looked in wp-config.php, but am hesitant to change anything since last time I tried to access this I got no such error and phpmyadmin worked fine. Has anyone run into a similar problem?

    Thanks.

    __
    # November 27, 2012 at 9:15 pm

    > I’m trying to access phpmyadmin locally for my WordPress site (using xampp), and am getting this error: “#1045 – Access denied for user ‘root’@’localhost’ (using password: NO) “

    …Meaning you have the wrong username/password.

    Did you change these when you installed xampp (user “root” with a blank password is the default)? Can you access your MySQL using the CLI or phpMyAdmin?

    # November 28, 2012 at 9:55 am

    I never changed this, so yes I am using the default values for user (root) and password (none). I can’t access phpmyadmin, when I try I get the above error. It’s strange. However, a solution would be to create a new database in the command prompt (since I can’t do this in phpmyadmin) and import my site’s database into here. Is there another way to create a new database, or is this my best bet?

    __
    # November 28, 2012 at 11:06 am

    > However, a solution would be to create a new database in the command prompt (since I can’t do this in phpmyadmin) and import my site’s database into here.

    What’s the point, if you still can’t access it?

    What version of xampp are you using? What version of Windows?

    You might try running `{your_xampp_directory}mysqlresetroot.bat` (STOP xampp first, restart afterwards).

    I’ve never had this problem before, and I don’t often use windows anymore. I do know that more recent versions of xampp ship with additional security features enabled by default. You can do things like changing your mysql password from `http://localhost/security`.

    # November 28, 2012 at 2:33 pm

    I’m using Xampp version 3.1.0, and Windows 7.

    __
    # November 28, 2012 at 3:45 pm

    You might look at these two methods of [setting a “root” MySQL password on Windows](http://www.apachefriends.org/en/faq-xampp-windows.html#5565).

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".