Grow your CSS skills. Land your dream job.

Jquery Slider not working.

  • # April 6, 2009 at 11:01 am

    Hello,

    I was wondering if someone could help me out. I’m trying to build out a jquery slider for my portfolio for a little to long. The problem I am having is that I can’t get it to work across all browsers mainly the newer update for Firefox which was a surprise to me. I know this is vague. I’m new to Javascript so I’m not so sure how to trouble shoot an issue like this. I have seen some really nice themes on themeforrest.com and those guys seem to get their sliders to work across all browsers. So does anyone have any tips on how to troubleshoot this or better yet can someone steer me to a slider that is cross browser compadible?

    I’m using this slider: http://www.gmarwaha.com/jquery/jcarousellite/1
    It doesn’t show up in firefox 3.0.8

    # April 6, 2009 at 11:23 am

    The demo slider on gmarwaha.com works in FF 3.0.8 on my Mac. Are you sure it’s not a CSS problem?
    Otherwise you can’t go wrong with this one http://cssglobe.com/post/4004/easy-slider-15-the-easiest-jquery-plugin-for-sliding

    # April 7, 2009 at 1:35 pm

    Weird. If I go to the site in Firefox it doesn’t show up.
    I only see the arrow buttons. Man, I wonder if my other designs were actually working…
    I’ll give the other slider a shot and report back.

    # April 7, 2009 at 1:38 pm

    Actually, now that I am taking a look at your link (http://cssglobe.com/post/4004/easy-slid … or-sliding) i have tried this one out to and I was having problems getting it to show up in all ie browsers. Granted, I was using the Developer toolbar in the new Safari beta. So that might be my problem right there. Maybe I will build a mock up and post to see if other people can do a quick check and see if it works.

    # April 8, 2009 at 8:28 pm

    Ok so here is a test I put together for my new portfolio site.
    I used easy slider. I think the problem I was having is I was checking browsers with Safari 4 Beta’s Developer add on.
    It doesn’t work well when testing Java Script I guess.
    If anyone could tell me this isn’t working on their browser, I would appreciate it. It does take a few seconds for the javascript
    to load.

    http://www.lrgstudios.com/vault/junk/ea … index.html

    # April 9, 2009 at 8:51 am

    It works fine in FF, Safari and Opera on the Mac. I have just checked on IE NetRenderer and it looks ok in IE6, 7 and 8 although obviously I can’t check if it actually works.

    # April 10, 2009 at 9:57 pm

    Having the images work was no problem but adding text and images together was a little tricky.
    I’ll post some new examples soon.
    I had to change the the css a bit to get this working right.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".