Grow your CSS skills. Land your dream job.

IE struck again!!

  • # December 22, 2011 at 11:07 pm

    Ok… I’m used to battling IE issues after I’ve got my site design beautiful in Chrome and Firefox… but this one takes the cake.

    This is also my first attempt at creating a WordPress Child Theme. I based it on the Twenty Eleven Theme.

    This is my site:
    http://gotburt.com/

    IE9… looks good.
    IE8… minor borked on the home page WP-Orbit Slider gallery for some reason
    IE7… major borked!! The majority site is just missing!!

    Does anyone have ideas what can cause this?!

    P.S. This is also my first attempt at a truly fluid down to mobile site. I’m trying to use the 960 grid system… and I think I’m doing it ok… but if anyone has any tips, advice… I’d love to hear it.

    # December 23, 2011 at 9:50 am

    This Link has a good list of know ie issues and fixes…

    # December 23, 2011 at 10:18 am

    Looks like your using some HTML5, but I don’t see the HTML5shiv in there. It’s good to include for IE 7/8 since they don’t understand any HTML5 elements. Here’s a link to the JS. See if that helps any.

    # December 23, 2011 at 11:44 am

    @Charlie – that’s a good link. I’m checking through it now.

    @tmette – no luck with adding the HTML5shiv.

    Since this was a child theme to twentyeleven, then it has the same HTML5 elements it had. It also had this line in the head already… which I assumed took care of the HTML five stuff:

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

*May or may not contain any actual "CSS" or "Tricks".